Notizie: scarica ora l'ultima versione disponibile di Firefox!

Autore Topic: PROBLEMA: componenti aggiuntivi disattivati o non funzionanti  (Letto 2428 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline microchip1967

  • Post: 6
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #30 il: 06 Maggio 2019 18:03:18 »
Buonasera a tutti e scusatemi se rompo le scatole (mi sono appena registrato)
In ufficio ho 9 pc con FF e su 5 di essi, per problemi di compatibilità con sistemi di videosorveglianza e telecontrollo (sono un installatore) e con le estensioni ho installato su questi pc e portatili la versione 51.0.1
Da sabato la magior parte delle estensioni ha cessato di funzionare.
Pensando ad un problema su uno dei pc ho utilizzato il backup fatto con Acronis. dopo il ripristino firefox ha ripreso correttamente a funzionare salvo,  dopo 10 minuti, trovarmi le estensioni nuovamente disattivate.
Ho fatto una ricerca e ho visto il problema
Una delle estensioni che mi ha disabilitato è adblock, senza la quale è praticamente impossibile navigare in alcuni siti
In questo momento le estensioni sono ancora disattivatre e non c'è verso di riattivarle.
Sugli altri pc temporaneamente ho installato brave per permettere almeno un uso decente della navigazione ma vorrei ripristinare il corretto funzionamento di firefox con le estensioni.
per la cronaca avevo già dovuto eseguire un downgrade dalla 63 alle 56 su una macchina virtuale per poter accedere al sito del Comitato Elettrotecnico Italiano per la consultazione delle norme (la 63 si impallava sulla gestione di file acrobat criptati)
Ho provato, seguendo le indicazioni sopra riportate, a ripristinare il profilo in appdata/roaming, appdata/local e program files con il risultato che al lancio di FF ho avuto immediatamente la segnalazione di estensioni disabilitate.
Se per caso qualcuno ha una possibile soluzione da suggerire gliene sarei grato. Non vorrei dover abbandonare il tutto dopo anni di uso (dalla versione 2 in avanti)

Offline Iceberg

  • Moderatore
  • Post: 7553
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #31 il: 06 Maggio 2019 18:12:16 »
Citazione
Questo profilo è buono da utilizzare visto che è salvato quando firefox è affetto da bug?
Potrebbe servire ma come ho scritto il riferimento era ad un backup fatto prima del bug.
Il backup utile è quello fatto quando non ci sono problemi.
Perché oltre alla disattivazione delle estensioni ci sono stati vari effetti collaterali.
Come puoi leggere Problemi noti e soluzioni sono un bell'elenco:
https://support.mozilla.org/it/kb/componenti-aggiuntivi-disattivati-non-installabili-firefox
Non tutte le soluzioni sono semplici e alcuni dati, se persi, non sono recuperabili.
Controlla se nella cartella extensions ci sono i file delle estensioni che avevi in precedenza.
Controlla che nella cartella storage/permanent/chrome/idb/ ci siano dei file (sono le impostazioni delle estensioni).
Se ci sono e non si sono attivate automaticamente dovrai riattivarle manualmente.


Citazione
Pensando ad un problema su uno dei pc ho utilizzato il backup fatto con Acronis. dopo il ripristino firefox ha ripreso correttamente a funzionare salvo,  dopo 10 minuti, trovarmi le estensioni nuovamente disattivate.
Se hai modo di farlo, ripristina nuovamente con il backup di Acronis. Questo fatto di ritrovarsi le estensioni disattivate dopo qualche minuto è stato risolto 5/6 ore fa.

Offline neofita 35

  • Post: 39
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #32 il: 06 Maggio 2019 18:59:52 »
Grazie Iceberg per la risposta.

Nella cartella extensions ho questo:



Nella cartella storage/permanent/chrome/idb/ ho questo
(le cartelle sono tutte vuote ma di file SQLITE ce ne sono diversi):


Però se ci sono non saprei quali sono le estensioni, ne avevo 10 ed alcune personalizzate.

Per sfortuna e guarda la strana casualità avevo fatto un ripristino di firefox non molto
tempo fa e  avevo elinato i dati scaricati sul dekpot il giorno prima che mi accorsi del bug di firefox.

Susa se mi ripeto, conviene aggiornare firefox automaticamente o eseguire firefox con i
diritti di amministratore dall'eseguibile della 66.0.4 scaricata dal sito (44.7mb)?

Grazie.

N.B. Scusami se non uso -citazioni- ma non sono ancora capace.
« Ultima modifica: 06 Maggio 2019 19:04:19 da neofita 35 »

Offline cunctator

  • Post: 565
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #33 il: 06 Maggio 2019 19:35:32 »
la mia esperienza è: non fare nulla, aspettare gli aggiornamenti automatici di firefox (per la versione ESR che uso e consiglio, l'ultimo, oggi, è 60.6.2 con fixed il bug di cui tanto si parla in questi giorni)...

Offline microchip1967

  • Post: 6
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #34 il: 06 Maggio 2019 21:05:08 »
Citazione
Se hai modo di farlo, ripristina nuovamente con il backup di Acronis. Questo fatto di ritrovarsi le estensioni disattivate dopo qualche minuto è stato risolto 5/6 ore fa.

Provata la soluzione del ripristino (fortunatamente il sistema è sempre attivo e i dati aziendali sono su un backup differente)
Ha retto per ben 12 minuti, dopodichè stesso messaggio (alcuni componenti aggiuntivi sono stati disattivati in quanto non è stato possibile disattivarli).....

Provato anche su uno dei portatili (con FF 50) stesso problema

Offline Iceberg

  • Moderatore
  • Post: 7553
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #35 il: 06 Maggio 2019 22:03:09 »
Su Firefox 50 dovresti risolvere facilmente impostando:
xpinstall.signatures.required = false
In caso riavvia e non volendo sopravvalutare quel facilmente è possibile che il false vada messo prima che parta il controllo, quando ancora tutto funziona. Provato su Firefox 52 da sabato e funziona, ma era false da sempre.

Per versioni più recenti, nelle quali quel parametro non ha effetto, sto facendo un esperimento. Aspetto almeno un'altra ora prima di darti un consiglio.

Chi utilizza versioni ancora supportate, 66 e 60 ESR, aspetti l'aggiornamento ufficiale, come dice sopra cunctator.


Offline p060477

  • Post: 1350
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #36 il: 06 Maggio 2019 22:04:18 »
Qualche informazione tecnica.
Il problema si instilla nel file extensions.json, correggerlo volendo è facile. Basta rimettere come valore 2 ove si trova -1, cambiare un false in true e un true in false. Questo per ogni estensione. Si salva riavvia e il problema è risolto.



grazie mille
non ho capito se questo trick funziona solo per un poco e dopo firefox ripresenti il bug
perdona la mia max ignoranza..
:(

PS...comunque ho aperto con wordpad il file..e l'ho richiuso subito..troppo difficile per le mie capacita' metterci mano
   senza la quasi certezza di combinare qualche grosso macello..grazie mille comunque Iceberg ;)
« Ultima modifica: 06 Maggio 2019 22:13:37 da p060477 »

Offline Iceberg

  • Moderatore
  • Post: 7553
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #37 il: 06 Maggio 2019 22:11:07 »
Nel mio caso funziona dalle 12 di oggi.

Al momento ti ritrovi con le estensioni disattivate in quanto non verificate?
Se sì ti va di fare un esperimento?

Offline p060477

  • Post: 1350
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #38 il: 06 Maggio 2019 22:17:30 »
ne avrei una, la no script, ma a scanso di equivoci voglio sottolineare bene che e' su una esr la 66.6.01 su cui -poggia torbrowser-
quindi ripeto essendo in realta' gestita da torbrowser,che di fatti non ha ancora fatto l'update alla 66.6.02esr, e' pacifico che su questo forum non diate assistenza
la mia quindi e' solo una testimonianza
ma ripeto la esr in questione poggia ed e' gestita dal progetto torbrowser
se quindi il mio scritto e' ot cancellatelo pure
io mi scuso in anticipo

Offline Iceberg

  • Moderatore
  • Post: 7553
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #39 il: 06 Maggio 2019 22:30:13 »
In questo caso meglio attendere l'aggiornamento ufficiale ed evitare esperimenti.
Per chiarire la situazione ti chiedo, solo l'estensione NoScript viene bloccata? Le altre no? Queste altre, se ce ne sono, sono normali estensioni o roba specifica di quel browser lì?

Offline p060477

  • Post: 1350
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #40 il: 06 Maggio 2019 22:41:24 »
si, in tutto sono 5, 4 senza problemi ed una,noscript,con una scritta warning
nel dettaglio:
ci sono 2 specifiche:tor botton e tor laucher ,
poi l'hotfix-update-xpi-intermediate che e' apparso dopo poco che e' nato il problema in questione
e la https everywhere
poi la la noscript che come ho scritto ha il bug  e riporta la scritta warning:
"non verificato:procedere con cautela"
grazie mille ancora Iceberg
« Ultima modifica: 06 Maggio 2019 22:43:37 da p060477 »

Offline Iceberg

  • Moderatore
  • Post: 7553
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #41 il: 06 Maggio 2019 23:30:36 »
Per versioni più recenti, nelle quali quel parametro non ha effetto, sto facendo un esperimento. Aspetto almeno un'altra ora prima di darti un consiglio.

@microchip1967

Hai ripristinato il backup fatto con Acronis e dopo 10 minuti il problema si è ripresentato. Ripetuta l'operazione con uguale esito.

Ora dovresti navigare all'interno del file di backup di Acronis, fino ad arrivare alla cartella del profilo di Firefox e recuperare il solo file extensions.json, con Firefox chiuso sostituisci questo file recuperato dal backup a quello attuale nel profilo. Riavvia. Funziona e soprattutto regge?

Ho fatto questa mossa alle 20, ora sono le 23:30 e nel mio caso funziona ancora. Mossa che temo dovranno fare tutti coloro che ripristineranno un backup funzionante, un ripristino in due fasi.

L'alternativa è editare questo file manualmente, funziona anche questo, dalla 12 di oggi. Chi non ha un backup, non vorrà attivare studi e telemetria (ammesso che funzioni questo tipo di soluzione) e se non arriverà una elegante soluzione dall'alto, dovrà percorrere questa strada. Difficile, forse, ma di soddisfazione, di sicuro.

Chiudo sperando di ritrovare domani queste soluzioni ancora valide. Passeranno la nottata?  :roll:

Offline p060477

  • Post: 1350
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #42 il: 06 Maggio 2019 23:44:18 »
"L'alternativa è editare questo file manualmente"..:
il problema e' che non mi pare,ma non sono un esperto..,semplice...
ci sono dentro una enormità di dati/parametri...
:(

Offline Iceberg

  • Moderatore
  • Post: 7553
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #43 il: 06 Maggio 2019 23:52:39 »
Hai un browser supportato.
Vediamo se il tutto passa la nottata.
Potrebbe arrivare una soluzione bella dall'alto.
Editare quel file è semplice se qualcuno ti dice cerca "abc" e cambialo con "cba".


Offline p060477

  • Post: 1350
Re:PROBLEMA: componenti aggiuntivi disattivati o non funzionanti
« Risposta #44 il: 07 Maggio 2019 07:07:31 »
Caro Iceberg
la nottata è passata e..la patch è arrivata..!..:)
ora rifunziona tutto come prima! :)
grazie mille!
la cartuccia del extensions.jason ce la spariamo un'altra volta
sempre se "un grosso pezzo di giaccio ma dal cuore caldissimo" ci guida a come -editarla-!!
grazie mille ancora di cuore!!
:)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.