Notizie: scarica ora l'ultima versione disponibile di Firefox!

Autore Topic: Non riesco a far visualizzare il logo nella firma HTML  (Letto 992 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Gabriel99

  • Post: 10
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #15 il: 14 Febbraio 2020 11:49:53 »
Salvando l'intero codice noto che non si visualizza neppure nel browser.
Se provi ad aprire solo l'immagine ti chiede il login di Google
Ho quindi recuperato l'indirizzo diretto dell'immagine e modificato il codice ed adesso sembra funzionare.
Se per te va bene te lo posso postare qui sul forum o inviare.

Davvero?? Grazieee!!!! ( come vuoi, se non si può qua sul forum va bene anche pastebin )

Buongiorno.
Eheheheh, le stesse prove che ho fatto ieri sera tardi. Solo che a me l'immagine non si apriva neppure dopo aver inserito il link diretto nel codice ... bah...
Però a me il testo, salvato come html si apre nel browser, sempre ovviamente senza immagine  :wink:
Resto sempre convinto che per l'immagine sia meglio non dipendere da nessun servizio esterno.   
 

quello che visualizzavo io è questo.

https://prnt.sc/r28eza


Offline Gabriel99

  • Post: 10
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #16 il: 14 Febbraio 2020 11:51:11 »
Solo che a me l'immagine non si apriva neppure dopo aver inserito il link diretto nel codice ... bah...

Si esatto, il link fornito sopra non porta all'immagine direttamente
Ho dovuto cliccare sull'immagine per visualizzarla in una nuova finestra e da li recuperare l'URL diretta tramite click destro :)

quindi mi stai dicendo che tutto sto casino perchè non ho copiato il link dell'immagine giusto??
 :oops: :sbat:

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23783
    • Mozilla Italia
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #17 il: 14 Febbraio 2020 11:52:37 »
Ma te l'avevo detto pure ieri: se anche da browser non lo visualizzi, il problema è dell'immagine, non di Thunderbird ;)

Offline Gabriel99

  • Post: 10
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #18 il: 14 Febbraio 2020 12:01:13 »
Ma te l'avevo detto pure ieri: se anche da browser non lo visualizzi, il problema è dell'immagine, non di Thunderbird ;)

eh avevo provato!
ma da come ho scritto qua io vedevo ogni volta l'immagine

Buongiorno.
Eheheheh, le stesse prove che ho fatto ieri sera tardi. Solo che a me l'immagine non si apriva neppure dopo aver inserito il link diretto nel codice ... bah...
Però a me il testo, salvato come html si apre nel browser, sempre ovviamente senza immagine  :wink:
Resto sempre convinto che per l'immagine sia meglio non dipendere da nessun servizio esterno.   


quello che visualizzavo io è questo.

https://prnt.sc/r28eza


[/quote]

che errore stupido....

Offline max1210

  • Post: 2609
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #19 il: 14 Febbraio 2020 12:11:16 »
Ho dovuto cliccare sull'immagine per visualizzarla in una nuova finestra e da li recuperare l'URL diretta tramite click destro :)
:shock: È quello che ho fatto anch'io ma senza visualizzarla poi alla successiva apertura.
 

Offline next

  • Post: 889
    • Seguimi su Libranet (Friendica)
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #20 il: 14 Febbraio 2020 14:15:22 »
Davvero?? Grazieee!!!! ( come vuoi, se non si può qua sul forum va bene anche pastebin )

Ok, provvedo appena torno al pc

Offline Gabriel99

  • Post: 10
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #21 il: 14 Febbraio 2020 17:20:13 »
Davvero?? Grazieee!!!! ( come vuoi, se non si può qua sul forum va bene anche pastebin )

Ok, provvedo appena torno al pc

Attendo, grazie ancora

Offline next

  • Post: 889
    • Seguimi su Libranet (Friendica)
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #22 il: 14 Febbraio 2020 18:12:35 »
Scusami ma da telefono era troppo complicato :)

Il link diretto all'immagine che ho usato è:
Codice: [Seleziona]
http://lh3.googleusercontent.com/ad-p-8xfZWVcQE0W89rWwsZ1TqQxwxTNYrG_O7ECXfAg2cj22L3eMyE4MLIwehfCDLq7_Ze1tapwNu-oKouCrmfsl2k9ImNLAkuyWRdWpXWR-YOOiNYGPHVQDFWXgIaUeEcQ7RmD=w148-h90-no

E questo è il codice modificato:
Codice: [Seleziona]
<table style="width: 1000px; font-size: 10pt; font-family: Arial, sans-serif; line-height: normal;" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="padding-top: 12px; padding-bottom: 12px; width: 10px;">&nbsp;</td>
<td style="padding-top: 12px; padding-bottom: 12px; width: 205px;">
<p><img src="https://lh3.googleusercontent.com/ad-p-8xfZWVcQE0W89rWwsZ1TqQxwxTNYrG_O7ECXfAg2cj22L3eMyE4MLIwehfCDLq7_Ze1tapwNu-oKouCrmfsl2k9ImNLAkuyWRdWpXWR-YOOiNYGPHVQDFWXgIaUeEcQ7RmD=w148-h90-no" width="219" height="133" /></p>
</td>
<td style="padding-top: 6px; padding-bottom: 6px; width: 447px;">
<table style="width: 314px;" cellspacing="0" cellpadding="0">
<tbody>
<tr>
<td style="font-size: 12pt; font-family: Arial, sans-serif; font-weight: bold; color: #3d3c3f; width: 324px;"><span style="font-family: Times New Roman, serif; color: #3d3c3f;">Gabriel Maggio</span></td>
</tr>
<tr>
<td style="padding-bottom: 11px; font-size: 10pt; font-family: Arial, sans-serif; color: #3d3c3f; width: 324px;"><span style="font-family: Times New Roman, serif; color: #3d3c3f;">Ufficio Bollettazione</span></td>
</tr>
<tr>
<td style="font-size: 10pt; font-family: Arial, sans-serif; color: #9b9b9b; width: 324px;"><span style="font-family: Times New Roman, serif; color: #000000;">Alba-Sped SRLs</span></td>
</tr>
<tr>
<td style="font-size: 10pt; font-family: Arial, sans-serif; color: #9b9b9b; width: 324px;"><span style="font-family: Times New Roman, serif; color: #000000;">Via Madrid 22</span></td>
</tr>
<tr>
<td style="font-size: 10pt; font-family: Arial, sans-serif; color: #3d3c3f; width: 324px;"><span style="font-family: Times New Roman, serif; color: #000000;">24040 Verdellino (BG)</span></td>
</tr>
<tr>
<td style="font-size: 10pt; font-family: Arial, sans-serif; color: #3d3c3f; width: 324px;"><span style="font-family: Times New Roman, serif; color: #000000;">Albo: BG/1158514/W</span></td>
</tr>
<tr>
<td style="padding-bottom: 11px; font-size: 10pt; font-family: Arial, sans-serif; color: #9b9b9b; width: 324px;"><span style="font-family: Times New Roman, serif; color: #000000;">SDI: 1YY4LRX </span></td>
</tr>
<tr>
<td style="font-size: 10pt; font-family: Arial, sans-serif; color: #9b9b9b; width: 324px;"><span style="font-family: Times New Roman, serif; color: #000000;">Cellulare: +39 339 144 1088</span></td>
</tr>
<tr>
<td style="font-size: 10pt; font-family: Arial, sans-serif; color: #9b9b9b; width: 324px;"><span style="font-family: Times New Roman, serif; color: #000000;">Tel. +39 035 67 3808 </span></td>
</tr>
</tbody>
</table>
</td>
</tr>
<tr>
<td style="border-top: 1px solid #000000; width: 662px; padding-top: 8px;padding-bottom: 8px; font-family: Arial, sans-serif; color: #9b9b9b; text-align: justify;" colspan="3"><span style="font-size: 11px; font-family: Times New Roman, serif; color: #000000;">Il contenuto di questa e-mail &egrave; confidenziale e destinato esclusivamente al destinatario specificato nel messaggio. &Egrave; severamente vietato condividere qualsiasi parte di questo messaggio con terze parti, senza il consenso scritto del mittente. Se hai ricevuto questo messaggio per errore, rispondi a questo messaggio e segui la sua eliminazione, in modo che possiamo garantire che tale errore non si verifichi in futuro.</span></td>
</tr>
<tr>
<td style="border-top: 1px solid #000000; border-bottom: 1px solid #000000; width: 662px; padding-top: 8px; font-family: Arial, sans-serif; color: #9b9b9b; text-align: justify;" colspan="3"><span style="font-size: 11px; font-family: Times New Roman, serif; color: #000000;">The content of this email is confidential and intended for the recipient specified in message only. It is strictly forbidden to share any part of this message with any third party, without a written consent of the sender. If you received this message by mistake, please reply to this message and follow with its deletion, so that we can ensure such a mistake does not occur in the future.</span></td>
</tr>
</tbody>
</table>

Offline bibbolo

  • Post: 835
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #23 il: 15 Febbraio 2020 15:24:18 »
Ho creato anche io una firma con logo per un account aziendale, e come max1210 ho ritenuto che fosse meglio avere una immagine locale per la firma. Ho pertanto seguito questa guida e ho ottenuto la mia firma con immagini. La cosa bella, che non sapevo, è che con questo procedimento l'immagine (che mi par debba essere necessariamente in png) viene trasformata in una sequenza di caratteri, pertanto la si può impostare sia sul client che nelle impostazioni firma delle webmail.

Del risultato ottenuto sono abbastanza soddisfatto, ma approfitto del thread per chiedere due dubbi.

Il primo, è che ho riscontrato che in alcune mail di risposta (se non ricordo male una era yahoo ma potrebbero essercene altre), nel testo originale copiato nella risposta, in cui c'era appunto la mia firma, questa si vedeva con il tipico quadratino bianco di immagine non visualizzabile. Può essere dovuto al sistema scelto o da impostazioni del provider che ha ricevuto la mail?

Il secondo, meramente estetico, riguarda la formattazione del testo. Ho infatti inserito anche un testo sotto il logo, che però appare allineato a sinistra mentre io lo vorrei giustificato sotto il logo; se modifico il tag per il giustificato mi viene spostato al centro della pagina e non al centro del logo. Immagino che il problema sia risolvibile adattando le solite tabelle, e mi ero prefissato di fare alcuni tentativi per lo scopo.. ma se nel frattempo qualcuno esperto con il codice html mi sa dare una soluzione semplice a partire dal codice della guida che ho menzionato prima (nello specifico quello presente nell'ultima immagine) mi farebbe risparmiare del tempo. :-)

Offline next

  • Post: 889
    • Seguimi su Libranet (Friendica)
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #24 il: 15 Febbraio 2020 15:41:43 »
Provo a risponderti per quella che è la mia esperienza

questa si vedeva con il tipico quadratino bianco di immagine non visualizzabile
Yahoo Mail (che uso da anni) ha una misura antispam per cui non carica le immagini da remoto. Se però l'immagine era inserita direttamente nella mail, il quadrato bianco dell'immagine mancante potrebbe essere dovuto ad un errore di visualizzazione. Tieni conto infatti che Yahoo Mail riconosce solitamente la parte della firma e non la riporta nelle risposte. Inoltre Yahoo Mail si può usare anche da client tramite POP o IMAP, ed in questo caso sono le impostazioni del programma a prevalere (molti scelgono di non visualizzare le immagini e l'html).

Ho infatti inserito anche un testo sotto il logo, che però appare allineato a sinistra mentre io lo vorrei giustificato sotto il logo

Bisognerebbe vedere il codice. In generale però io sconsiglio di utilizzare le tabelle ed il tag font. All'apparenza permettono di ottenere firme graficamente gradevoli, ma è alto il rischio che le stesse siano visualizzate male da chi le riceve perché questi elementi vengono gestiti in maniera diversa a seconda del programma e del sistema operativo utilizzato.

Offline max1210

  • Post: 2609
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #25 il: 15 Febbraio 2020 17:12:54 »
Buonasera.
A quanto scritto da @next, che condivido, mi permetto aggiungere che alcuni provider e/o sistemi di protezione quando trovano un link all'interno di una Firma che considerano sospetto (perché rimanda ad un cloud o altro sito), non sempre lasciano passare il messaggio mettendolo magari in quarantena o Spam.

Riguardo alla tabella: ultra d'accordo.
Inoltre, essendo le dimensioni obbligate-preimpostate, se il destinatario usa una finestra piccola per visualizzare le mail ecco che questa firma appare troncata anziché adeguarsi alle dimensioni dello spazio.
Per i Font credo che oggi la questione sia un po' più "flessibile" considerato il set di elementi disponibili nei SO maggiore rispetto al passato, lo vedo un problema come indicato quando si utilizzano Font particolari poco noti o difficili da reperire.
Ma chi installa un particolare tipo di Font solo per visualiizare una Firma nella mail?  :?       
   

Offline max1210

  • Post: 2609
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #26 il: 15 Febbraio 2020 18:54:12 »
Buonasera.
... Ho infatti inserito anche un testo sotto il logo, che però appare allineato a sinistra mentre io lo vorrei giustificato sotto il logo; ...
Dove trovi i parametri per comporre la scritta credo sia sufficiente inserire per dare un margime a sx questo parametro: margin-left 3px; (Il 3 è solo per un esempio lo cambi secondo le tue esigenze.)
Ma @next o chi pratico di html ti sapranno dare indicazioni più precise :wink:   

Offline bibbolo

  • Post: 835
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #27 il: 15 Febbraio 2020 19:32:20 »
alcuni provider e/o sistemi di protezione quando trovano un link all'interno di una Firma che considerano sospetto (perché rimanda ad un cloud o altro sito), non sempre lasciano passare il messaggio mettendolo magari in quarantena o Spam.
Motivo per cui anche io concordo con te sulla scelta di un'immagine non "remota". Inoltre anche ammesso che venga riconosciuta tutto ciò che oggi risiede su un server non è detto che vi sarà anche domani.

Riguardo alla tabella: ultra d'accordo.
Nel senso che la sconsigli anche tu? L'autore della discussione ha la tabella, magari ci posterà eventuali feedback sulla visualizzazione in futuro.
Comunque la tabella mi sembra molto utilizzata nelle firme professionali aziendali..

Dove trovi i parametri per comporre la scritta credo sia sufficiente inserire per dare un margime a sx questo parametro: margin-left 3px; (Il 3 è solo per un esempio lo cambi secondo le tue esigenze.)
No in questo caso credo che lui allinei prendendo come riferimento lo spazio generale e non quello "sotto" il logo, per questo presumo che ci voglia un qualche contenitore (div o tabella) che ne imponga la posizione richiesta.
Comunque il codice, copiato dalla pagina che avevo menzionato (edit: ricordavo di averlo copiato come nella guida, ma da thunderbird vedo ora che non è presente il tag div), è questo:

Codice: [Seleziona]
<p><img src="data:image/jpeg;base64,CARATTERIPERLACODIFICAINIMMAGINE"
    alt="" width="193" height="77"> </p>
<p><font color="#cc0000"><font size="-1"><b>Testo personale</b><br>Testo personale<br>
        Testo personale</font></font><br>
</p>
« Ultima modifica: 15 Febbraio 2020 19:37:39 da bibbolo »

Offline max1210

  • Post: 2609
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #28 il: 15 Febbraio 2020 21:40:25 »
Spostando un pò l'immagine dal bordo sx e ricentrando il testo sotto a questa potrebbe essere una cosa così:
Codice: [Seleziona]
<body style="margin-left: 30px";
<p><img src="data:image/jpeg;base64,CARATTERIPERLACODIFICAINIMMAGINE"
    alt="" width="193" height="77"> </p>
<p style="margin-left: 40px;">
<font color="#cc0000"><font size="-1"><b>Testo personale</b><br>Testo personale<br>
        Testo personale</font></font><br>
</p>

Cambiando i numeri dei px sposti l'immagine e/o testo. Tieni presente che quelli del body style spostano -tutto- mentre quelli del p style tutta e solo la parte del testo all'interno del body.
Non è escluso che il mio sia un sistema barbaro e poco elegante derivato dall'uso improvvisato e sperimentale dei comandi, vedi se qualcuno afferrato in materia lo corregge nei dovuti modi  :P         

Offline bibbolo

  • Post: 835
Re:Non riesco a far visualizzare il logo nella firma HTML
« Risposta #29 il: 16 Febbraio 2020 16:03:04 »
Ti ringrazio per la risposta. Tuttavia in questo modo il testo rimane allineato a sinistra, si sta solo spostando il tutto più a destra. Io vorrei sì spostarlo più a destra, in sostanza centrale sotto il logo, ma giustificato e non allineato a sinistra..

0 Utenti e 1 Visitatore stanno visualizzando questo topic.