Notizie: puoi sempre seguire i nostri aggiornamenti su Twitter (@MozillaItalia) e Facebook (/MozillaItalia)

Autore Topic: TB3: bug cache immagini  (Letto 2549 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline sidvizioso

  • Post: 30
TB3: bug cache immagini
« il: 02 Gennaio 2010 21:08:53 »
salve,
ho appena installato TB3 ma ho notato subito un bug (o errore di configurazione??).

Ricevendo una newsletter da parte di un mio cliente ho notato che le immagini sono sempre quelle della newsletter precedente, come se le prendesse dalla cache.. Ne ho inviate varie e sempre lo stesso risultato. Ora non capisco come risolvere il problema e se sia un bug. Ho provato a vedere le email direttamente dalle webmail online e lì le immagini sono corrette.
Cosa posso fare? è un bug o un problema di configurazione?

grazie a tutti in anticipo

Offline sidvizioso

  • Post: 30
Re: TB3: bug cache immagini
« Risposta #1 il: 02 Gennaio 2010 21:24:16 »
ho provato anche a creare una nuova mail direttamente da TB con una immagine preso dal sito del mio cliente e anche in questo caso prende una foto da qualche vecchia email.. questo è un bug grave...

Offline Gioxx

  • Amministratore
  • Post: 7728
    • Gioxx's Wall
Re: TB3: bug cache immagini
« Risposta #2 il: 03 Gennaio 2010 04:16:04 »
Giusto per tua informazione Thunderbird non mantiene una cache di quanto scaricato oltre la chiusura della finestra del client.
In parole povere chiudi il programma e riaprilo, ora vai a pescare la mail incriminata e controlla che carichi le giuste immagini.

Nulla è cambiato? Ciò vuol dire che la cache è quella del tuo browser, difficile che possa essere quella del tuo client di posta. Immagino che il tuo cliente carichi le immagini online (sul suo spazio web?) e le richiami nella mail (che invierà poi a tutti) con un apposito indirizzo "http: //SITO.TLD/IMMAGINE.JPG", giusto?

Provato ad aprire quell'indirizzo con il tuo browser e controllare cosa compare? Provato a forzare un aggiornamento di quell'immagine (CTRL + R o F5) per controllare che questa cambi davvero?

Ciao!

Offline sidvizioso

  • Post: 30
Re: TB3: bug cache immagini
« Risposta #3 il: 03 Gennaio 2010 19:42:48 »
Citazione
Provato ad aprire quell'indirizzo con il tuo browser e controllare cosa compare? Provato a forzare un aggiornamento di quell'immagine (CTRL + R o F5) per controllare che questa cambi davvero?

certo che ho fatto queste prove, mi sono espresso male ma ho già provato. e come ripeto
Citazione
Ho provato a vedere le email direttamente dalle webmail online e lì le immagini sono corrette.

quindi qual'è il problema?

Offline sidvizioso

  • Post: 30
Re: TB3: bug cache immagini
« Risposta #4 il: 04 Gennaio 2010 17:19:23 »
altro test ennesimo problema riscontrato.
sono tornato in ufficio oggi, nuova newsletter. su tutti i pc è arrivata con le giuste immagini, sul mio pc, usando TB, è arrivata ma con le immagini della precedente mail di cui parlavo nel post precedente. praticamente mantiene esattamente le immagini precedenti...
mi sembra incredibile..

Offline AlexV

  • Post: 2199
    • Evolution Club
Re: TB3: bug cache immagini
« Risposta #5 il: 04 Gennaio 2010 17:51:33 »
Puoi per curiosità fare una prova?

Nell'editor di configurazione (Strumenti -> opzioni -> avanzate clicca sul pulsante Editor di Configurazione) nel campo "filtro" inserisci "cache".

nella lista che ti appare hai dei valori in grassetto?

Offline sidvizioso

  • Post: 30
Re: TB3: bug cache immagini
« Risposta #6 il: 04 Gennaio 2010 18:15:32 »
in grassetto ho solo questo:

intl.charsetmenu.mailview.cache --> ISO-2022-JP, GB2312, windows-1252, UTF-8, ISO-8859-15

forse devo disabilitare alcuni valori di cache che sono ora impostati a true?

cmq il problema sussiste perchè la newsletter utilizza un template predefinito e i nomi delle immagini sono sempre le stesse, immagini residenti nel webserver. Cambiando i nomi il problema scompare. cmq voglio capire come risolvere il tutto.

ps grazie per la risposta

Offline AlexV

  • Post: 2199
    • Evolution Club
Re: TB3: bug cache immagini
« Risposta #7 il: 05 Gennaio 2010 09:59:17 »
in grassetto ho solo questo:

intl.charsetmenu.mailview.cache --> ISO-2022-JP, GB2312, windows-1252, UTF-8, ISO-8859-15


Fammi fare qualche prova, poi ti dico :)

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 24618
    • Mozilla Italia
Re: TB3: bug cache immagini
« Risposta #8 il: 05 Gennaio 2010 10:39:20 »
Io comunque vedo che la cache esiste. Tra le impostazioni avanzate ("Rete e spazio su disco") vedo anche che è possibile svuotarla.

Hai già provato a modificare questo parametro per vedere se cambia qualcosa?

http://kb.mozillazine.org/Browser.cache.check_doc_frequency

Offline AlexV

  • Post: 2199
    • Evolution Club
Re: TB3: bug cache immagini
« Risposta #9 il: 05 Gennaio 2010 15:18:47 »
Ciao!

ho fatto qualche prova ed effettivamente con i settaggi standard anche creando una semplice mail in HTML con immagini, modificando queste ultime sul server senza rinominarle, TB continua a mostrare la prima immagine.

impostando dall'editor di configurazione il parametro network.http.use-cache su false mi sembra che il problema sia risolto  :D

Si risolve ugualmente, come indicato da Underpass, impostando il valore browser.cache.check_doc_frequency su 1 (forse è pure meglio) :)
« Ultima modifica: 05 Gennaio 2010 15:30:37 da AlexV »

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 24618
    • Mozilla Italia
Re: TB3: bug cache immagini
« Risposta #10 il: 05 Gennaio 2010 15:58:08 »
In ogni caso probabilmente il bugghettino c'è. Mi piacerebbe sentire l'opinione di flod e prometeo ed eventualmente costruire un testcase.

Offline flod

  • Amministratore
  • Post: 15057
    • http://www.flod.org
Re: TB3: bug cache immagini
« Risposta #11 il: 05 Gennaio 2010 16:33:11 »
Ho trovato questo
https://bugzilla.mozilla.org/show_bug.cgi?id=383336

Chiuso come duplicato di questo
https://bugzilla.mozilla.org/show_bug.cgi?id=404922

Il sommario non è il massimo (parla di drag&drop), ma ci sono una marea di bug correlati :?

0 Utenti e 1 Visitatore stanno visualizzando questo topic.