Notizie: se possiedi un dispositivo Android, prova Firefox per Android, un browser scattante e dinamico per navigare in ambiente mobile.

Autore Topic: Mozilla Firefox 3.6 Beta 2: Le immagini flottate vanno a finire come sfondo.  (Letto 3968 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Spero non venga considerato come spam, anche perchè non sono nessuno in quel sito, ma è dove mi si presenta questo problema: http://tinyurl.com/m3zcr7
Le immagini delle sezioni vanno a finire dietro al desto, mentre se faccio un refresh tutto si visualizza normalmente. Con la versione stabile di FF non mi capitava mai questo errore. Per chi non capisce l'errore ecco un'immagine esemplificativa:


Attendo chiarimenti in merito.

Offline flod

  • Amministratore
  • Post: 15015
    • http://www.flod.org
Ho provato a caricare la pagina ma non ho verificato il problema. Riesci a fare una prova su un profilo pulito? Che estensioni stai usando?

Profilo di firefox nuovo? Sto chiedendo ad un amico di farlo per me.

Utilizzo le seguenti estensioni attive:
Adblock Plus 1.1.1

Installate ma disattive:
Firebug 1.4.5
Java Quick Starter 1.0
Microsoft .NET Framework Assistant 0.0.0

Offline michro

  • Moderatore
  • Post: 18823
Si, profilo di Firefox: nuovo profilo (<-clic)

Le estesioni Java Quick Starter 1.0 e Microsoft .NET Framework Assistant 0.0.0 creano spesso problemi,
se vuoi disinstallarle leggi l'articolo
http://support.mozilla.com/it/kb/Impossibile+disinstallare+un+componente+aggiuntivo
paragrafo "Estensioni installate da altri programmi".
« Ultima modifica: 15 Novembre 2009 14:47:21 da michro »

Ha provato con Mozilla appena installato e ha lo stesso mio problema, sembra un errore di parsing.

Offline Bogio12

  • Post: 1
Confermo, sono il suo amico, appena installato FF, si vedono male tutte le sezioni, anche le prime due...

http://i35.tinypic.com/2j2euxv.png

Offline flod

  • Amministratore
  • Post: 15015
    • http://www.flod.org
Ho provato ma non riesco a riprodurre il problema nemmeno su una nightly con Windows 7.

Ho comunque il dubbio che il problema sia legato a come caricano il css principale (mai visto fare in questo modo) :?
Codice: [Seleziona]
<link href="./style.php?sid=a7dbc6075372bb8f48b85fa3b40ebccd&amp;id=3&amp;lang=en" rel="stylesheet" type="text/css" media="screen, projection" />

Ho provato ma non riesco a riprodurre il problema nemmeno su una nightly con Windows 7.

Ho comunque il dubbio che il problema sia legato a come caricano il css principale (mai visto fare in questo modo) :?
Codice: [Seleziona]
<link href="./style.php?sid=a7dbc6075372bb8f48b85fa3b40ebccd&amp;id=3&amp;lang=en" rel="stylesheet" type="text/css" media="screen, projection" />

Per questo non ci sono problemi, è un file dinamico, ma l'header inviato è di tipo text/css quindi è come se il file avesse estensione css per dirla in parole povere.

Non capisco però perché il problema si presenta solo in questa versione, mentre nelle precedenti, IE, Chrome, Opera e Safari non si presenta.

Offline flod

  • Amministratore
  • Post: 15015
    • http://www.flod.org
Per questo non ci sono problemi, è un file dinamico, ma l'header inviato è di tipo text/css quindi è come se il file avesse estensione css per dirla in parole povere.
Non capisco però perché il problema si presenta solo in questa versione, mentre nelle precedenti, IE, Chrome, Opera e Safari non si presenta.
Onestamente non saprei dirtelo. Il codice della pagina è sicuramente più complesso della media, ma è valido, per cui non vedo perché dovrebbe incontrare problemi con il parsing. Sembra quasi che si incarti nella gestione dei float (quindi più rendering che parsing).

L'unica strada è provare ad aprire un bug su BugZilla e vedere se qualcuno è in grado di darti una risposta ;-)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.