Notizie: puoi sempre seguire i nostri aggiornamenti su Twitter (@MozillaItalia) e Facebook (/MozillaItalia)

Autore Topic: problemi con simboli e accenti  (Letto 2194 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

problemi con simboli e accenti
« il: 07 Gennaio 2008 11:39:56 »
ho installato Thunderbird da poco e ho problemi quando nei testi sono presenti simboli e accenti.
per esempio, una mail il cui subject inizia con una parentesi quadra viene visualizzata con un punto interrogativo.

peggio ancora con le mail importate da Eudora: il testo si interrompe ogni volta che è prsente un carattere accentato o un simbolo.

ha impoortato intere cartelle di messaggio che poi sono risultati vuoti o incompleti.

ora ho reinstallato Thunderbird: come posso procedere per evitare il problema?

grazie

Offline Almotasim

  • Post: 1502
Re: problemi con simboli e accenti
« Risposta #1 il: 07 Gennaio 2008 17:42:35 »
Il problema potrebbe dipendere dal fatto che le mail sono malformate, se (togliendovi i dati per te sensibili) posti il sorgente di una di queste (la apri e poi vai nel menu Visualizza -> Sorgente del messaggio) magari gli esperti confermano/smentiscono...

P.S.: Se vai nel menu Visualizza (stavolta di Thunderbird, non in quello di un messaggio aperto) e selezioni la voce Codifica caratteri, che cosa hai spuntato?

Offline cecca

  • Post: 6456
Re: problemi con simboli e accenti
« Risposta #2 il: 07 Gennaio 2008 17:48:43 »
Che tipo di codifica hai impostato per i caratteri? Mi sa che il problema è tutto lì....

Re: problemi con simboli e accenti
« Risposta #3 il: 07 Gennaio 2008 18:46:10 »
Che tipo di codifica hai impostato per i caratteri? Mi sa che il problema è tutto lì....

nelle preferenze ho impostato ISO 8859-1 e UTF-8 prima di importare i messaggi da Eudora, e in entrambi i casi la posta importata ha questo problema (messaggi vuoti o troncati).

ho provato a visualizzare il sorgente dei messaggi importati e sono tutti troncati, a volte dopo l'header, a volte in un punto del messaggio che in genere coincide con una lettera accentata.

in eudora non so come vedere il sorgente di questi messaggi

la mail (scaricata con TB) il cui subject mi appare solo come   ?
visualizzando il sorgente è così

Content-Type: text/plain; charset=utf-8
Subject: =?utf-8?Q?=5bFlickr=5d_Sei_il_contatto_pi=fa_recente_di_lutherblissett=37=31=21?=

in un messaggio importato che mi appare vuoto se vedo il sorgente dopo gli header trovo questo e poi il nulla

Content-transfer-encoding: 7bit


mi sembra di capire che è un problema a monte, o nel modo in cui eudora codifica i messaggi o nel modo in cui TB li importa.

spero di poterlo risolvere perché ho 5 anni di archivio posta che vorrei non perdere

Offline Almotasim

  • Post: 1502
Re: problemi con simboli e accenti
« Risposta #4 il: 07 Gennaio 2008 20:38:14 »
Per la serie "Idee balzane", potresti provare ad aggirare il problema importando la posta prima da Eudora ad Outlook e poi da Outlook a Thunderbird... :?

Che estensione hanno i file di posta di Eudora?
Non è che magari (boiata nr. 2) sono mbox?
In questo caso potresti provare con questa estensione...

Re: problemi con simboli e accenti
« Risposta #5 il: 07 Gennaio 2008 22:33:48 »
i file delle mailbox di eudora non hanno nessuna estensione...

p.s. dimenicavo di dire che lavoro su Mac con system 10.4.11

Offline klades

  • Moderatore
  • Post: 5782
    • http://www.nic-nac-project.org/~kaosmos
Re: problemi con simboli e accenti
« Risposta #6 il: 08 Gennaio 2008 13:11:56 »
I file di eudora sono in formato mbox, ma, a quel che so, usano un formato mbox non standard (sto parlando di formato non di estensione del file).
Prova a leggere questo: http://kb.mozillazine.org/Thunderbird_:_Issues_:_Import_From_Eudora e anche questo http://homepage.mac.com/aamann/Eudora_Mailbox_Cleaner.html

Re: problemi con simboli e accenti
« Risposta #7 il: 08 Gennaio 2008 18:05:01 »
I file di eudora sono in formato mbox, ma, a quel che so, usano un formato mbox non standard (sto parlando di formato non di estensione del file).
Prova a leggere questo: http://kb.mozillazine.org/Thunderbird_:_Issues_:_Import_From_Eudora e anche questo http://homepage.mac.com/aamann/Eudora_Mailbox_Cleaner.html

sembra che funzioni! adesso vado a controllare nel dettaglio le varie cartelle, forse due o tre mail si sono perse nel processo di importazione, ma ora vedo tutti i messaggi senza problemi di interruzione né di codifica.

se trovo qualche baco ve lo segnalo, comunque grazie !!!

0 Utenti e 1 Visitatore stanno visualizzando questo topic.