Autore Topic: <R> Problema con FireFox files FLASH (SWF) e W3C  (Letto 10379 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline actze

  • Post: 5
<R> Problema con FireFox files FLASH (SWF) e W3C
« il: 10 Gennaio 2005 15:41:26 »
Salve a tutti non capisco perchè Firefox e/o Mozilla visualizzano diversamente da IExplorer (e sbagliando) molti siti Web.

http://www.colclocks.com/FlashClocks/fc7desetembro/fc7desetembro.html

Per esempio se apro questo clock flash su IExplorer lo visualizza correttamente mentre Firefox no (non tiene conto dei tag width e height)

Ho cercato nel vostro forum per problemi analoghi e ho trovato vari threads ma non ho capito qual'è il problema. Per esempio conj il validator del W3c si ottengono messaggi di errore su dei tags come se questi non esistessero, tipo appunto il tag width o height, quando questi ultimi esistono eccome, tanto che IExplorer li usa per visualizzare correttamente la pagina

p.s. Ottengo gli stessi problemi di visualizzazione nel mio sito web www.sienasconti.it e vorrei capire dove ho sbagliato nel codice flash

Offline halifax

  • Post: 5904
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #1 il: 10 Gennaio 2005 15:55:07 »
:?A me il sito non da nessun problema,anche navigandoci all'interno mi sembra tutto ok,scusa ma cosa dovrebbe venire visualizzato che invece a te non compare?
Domanda forse scontata hai i plug in giusti installati?Non vorrei invece fosse un problema di activex,perchè ho provato anche con  ie 6 sp2 e mi compare l'avviso di autorizzare o meno l'installazione di un controllo activex appunto(per altro forse sicuro perchè è della macromedia)
Ciao :)

Offline actze

  • Post: 5
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #2 il: 10 Gennaio 2005 16:08:08 »
immaginavo che il problema fosse sui miei plugins, ma non capisco come, nel senso che il plugin flash di iexplorer mi funziona bene, mentre quello su firefox no... ma come posso aver sbagliato se l'ho semplicemente installato la prima volta che ho aperto il sito con firefox che mi ha chiesto di scaricare il plugin fornendomi già il link?

cmq ecco il link a una foto del sito come me lo visualizza firefox, sbagliando  :?:  :roll:
http://www.sienasconti.it/images/erroremozilla.jpg

Offline halifax

  • Post: 5904
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #3 il: 10 Gennaio 2005 16:32:08 »
:? Nel post precedente scusami ma mi ero dimenticato di dirti che ero andato anche su l'altro sito che avevi insicato,e anche lì nessun problema(a maggior ragione ora che hai inserito uno screenshot,a proposito ma stiamo parlando sempre di ff,giusto?No perchè dall'immagine che hai postato mi sembra mozilla,può essere?),comunque fai così (tanto vale in entrambi i casi) digita sulla barra indirizzi il comando about:plugins e controlla se nella schermata che ti compare risulta installato il plug in flash(in caso contrario lo devi reinstallare,e non centra se lo hai già in ie),facci sapere poi com'è andata.
Ciao

Offline actze

  • Post: 5
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #4 il: 10 Gennaio 2005 16:47:11 »
esatto il problema ce l'ho anche su firefox che tra l'altro uso su un altro computer con windows xp (a lavoro ho mozilla su win2000)

cmq l'info sui plugins sul flash mi dice questo, quindi sembrerebbe che il plugin ce l'abbia installato. Che mistero?!?!

Shockwave Flash

    File name: NPSWF32.dll
    Shockwave Flash 7.0 r19

MIME Type    Description    Suffixes    Enabled
application/x-shockwave-flash    Macromedia Flash movie    swf    Yes
application/futuresplash    FutureSplash movie    spl    Yes

Offline halifax

  • Post: 5904
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #5 il: 10 Gennaio 2005 16:56:02 »
:? E infatti i parametri sono quelli giusti,che estensioni hai installate se c'è l'hai?In particolare qualcosa tipo flash block o adblock?
Poi prova anche,nel caso ancora non lo avessi fatto,a crearti un nuovo profilo ed usalo per riaccedere di nuovo al sito e vedere se ti da problemi.
La procedura la trovi qui:
http://forum.mozillaitalia.org/viewtopic.php?t=5375
Ciao

Offline actze

  • Post: 5
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #6 il: 10 Gennaio 2005 17:55:07 »
non uso flash blocker o roba simile. Ho creato un nuovo profilo, ho lanciato Mozilla ma www.sienasconti.it mi viene visualizzato sempre male (come prima) anche facendo reload vari

Offline flod

  • Amministratore
  • Post: 15058
    • http://www.flod.org
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #7 il: 10 Gennaio 2005 20:12:02 »
Per quanto riguarda www.sienasconti.it il problema è nel codice.

Tu inserisce il movie Flash con questo codice
Codice: [Seleziona]
<object classid="clsid:D27CDB6E-AE6D-11CF-96B8-444553540000" id="obj1" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" width="100" height="100">
<param name="movie" value="classic.swf">
<param name="quality" value="High">
<PARAM NAME=scale value=noborder>
<PARAM NAME=wmode>
<PARAM NAME=bgcolor VALUE=#000000>
<embed src="classic.swf" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" name="obj1"></object>

Il tag object viene usato da IE e contiene altezza e larghezza che non sono dichiarate nel tag EMBED; prova a modificare il tag EMBED in questo modo
Codice: [Seleziona]
<embed src="classic.swf" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" name="obj1" height="100" width="100"> e vedrai che il filmato diventerà 100x100

Il mio consiglio è comunque di provare a validare quella pagine e verificare il numero di errori presenti.
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.sienasconti.it%2F

P.S. sposto in Evangelizzazione

Offline flod

  • Amministratore
  • Post: 15058
    • http://www.flod.org
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #8 il: 10 Gennaio 2005 20:29:21 »
Per quanto riguarda il primo sito, il problema non è nel codice con cui è inserito il flash movie ma nel codice circostante.

Per verificarlo fai questa prova, salva la pagina web completa in locale con Firefox, poi modifica il codice della pagina togliendo il paragrafo che include il filmato: vedrai che l'orologio verrà visualizzato tranquillamente al 100%

In pratica da così
Codice: [Seleziona]
<td><p align="center">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" id="7desetembro" align="" height="96%" width="89%">
 <param name="movie" value="7desetembro.swf"> <param name="menu" value="false"> <param name="quality" value="high"> <param name="wmode" value="transparent"> <param name="bgcolor" value="#333333">
  <embed src="fc7desetembro_files/7desetembro.swf" menu="false" quality="high" wmode="transparent" bgcolor="#333333" name="7desetembro" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" align="" height="100%" width="100%"></object>
      </p></td>

a così
Codice: [Seleziona]
     <td>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" id="7desetembro" align="" height="96%" width="89%">
 <param name="movie" value="7desetembro.swf"> <param name="menu" value="false"> <param name="quality" value="high"> <param name="wmode" value="transparent"> <param name="bgcolor" value="#333333">
  <embed src="fc7desetembro_files/7desetembro.swf" menu="false" quality="high" wmode="transparent" bgcolor="#333333" name="7desetembro" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" align="" height="100%" width="100%"></object>
      </td>

Offline flod

  • Amministratore
  • Post: 15058
    • http://www.flod.org
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #9 il: 10 Gennaio 2005 20:41:09 »
Concludo: dai un'occhiata a questa pagina per capire come inserire flash e mantenere la compatibilità con gli standard
http://www.alistapart.com/articles/flashsatay/

Citazione
Per esempio conj il validator del W3c si ottengono messaggi di errore su dei tags come se questi non esistessero, tipo appunto il tag width o height, quando questi ultimi esistono eccome, tanto che IExplorer li usa per visualizzare correttamente la pagina
Lo standard per quel determinato doctype non prevede quei tag: il fatto che Internet Explorer li visualizzi non significa davvero nulla :wink:

Offline actze

  • Post: 5
<R> Problema con FireFox files FLASH (SWF) e W3C
« Risposta #10 il: 13 Gennaio 2005 12:02:55 »
grazie mille della risposta, superesaustiva!!!

Spero che questo thread torni utile anche ad altri utenti

0 Utenti e 1 Visitatore stanno visualizzando questo topic.