Notizie: scarica ora l'ultima versione disponibile di Thunderbird!

Autore Topic: Password principale (master password) sempre richiesta all'avvio di Firefox  (Letto 1547 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline markinson

  • Post: 45
Salve a tutti.  :)

Il problema indicato nel titolo è improvvisamente sorto oggi, in un elaboratore con Windows 10 Pro versione 1809 (in lingua inglese) e Firefox 63.0.3 64bit (in lingua inglese).
La pagina principale del browser è Google, ma nei vari tentativi ho anche impostato una pagina bianca o altra home page, tuttavia la situazione non cambia: appena lancio Firefox viene proposta la finestra di popup per l'inserimento della "password principale" (o "master password", che dir si voglia).
Se non sbaglio, peraltro è la stessa modalità di approccio che offre la suite SeaMonkey. Voglio dire: se in SeaMonkey è impostata una "master password", lanciando il browser o il gestore di posta, indifferentemente, viene comunque nell'immediato richiesto l'inserimento della password principale. In Firefox questo comportamento, almeno nel mio caso, è saltato fuori oggi.

Ho cercato di ricreare in altre macchine la situazione generale di partenza esistente sulla macchina con il "problema", ma il fenomeno non si presenta.

In un primo momento ho creduto che potesse dipendere da qualche malware, quindi ho effettuato ogni accurato e approfondito controllo: nessun esito.
L'antivirus installato è Kaspersky Free v 19.0.0.1088ab.
I controlli per la presenza di programmi indesiderati sono stati eseguiti con Malwarebytes' Anti-Malware, AdwCleaner e SUPERAntiSpyware: nessun esito.

Ho pensato allora di ripristinare un'immagine dell'elaboratore ad un momento in cui ero certo che tale richiesta non venisse presentata.
In un primo momento è andato tutto bene, ma dopo l'installazione dell'aggiornamento cumulativo di novembre di Windows (almeno questa è l'unica "cosa nuova" che è intervenuta) con successivo riavvio, poi, lanciato Firefox, la finestra di popup con richiesta della password principale è spuntata fuori di nuovo.

Infine, preciso che:
  • non ho un account Firefox-Sync;
  • sono intervenuto come suggerito in questo post, ossia rinominato/eliminato i file pkcs11.txt e secmode.db, però senza i risultati sperati.

Ok, non è la fine del mondo, anche perché disattivando tra le opzioni la richiesta della "master password", la finestra di popup non si ripresenta. Eppure vorrei capire il perché.

Puntualizzo ancora e in ultimo che, una volta lanciato Firefox e chiusa la finestra di popup della "password principale" (senza averla quindi inserita), quando capito in un sito dove in effetti dovrebbe apparire la richiesta di introdurre la "master password", allora la finestra di popup regolarmente compare e introdotta la dovuta password principale appaiono correttamente caricate le chiavi di accesso al sito.

Qualche suggerimento?

Grazie infinite per l'attenzione. ;)

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23646
    • Mozilla Italia
Ciao, non ho grandissima esperienza di password principale ma se non sbaglio dovrebbe intervenire la prima volta che si presenta una richiesta di inserimento password. Questo può capitare ad esempio se hai qualche estensione che fa login su una casella di posta, se hai un proxy che chiede le credenziali ecc. ecc.
Dovresti quindi magari anche elencare le estensioni installate.

Mi pare anche che ci fosse un problema, qualche tempo fa, relativo alla password principale e ad alcune richieste inutili. Se trovo il riferimento al bug lo posto qui.

Offline markinson

  • Post: 45
Ciao Underpass:)
Grazie infinite della tempestiva risposta.  :like:

Cercando, da stamattina, avevo notato anch'io che, soprattutto in passato, il modulo di gestione della "master password" aveva creato qualche problema.

Proprio perché è da stamattina che combatto e, mosso dalla disperazione  :shock: , sono arrivato a chiedere aiuto anche in un forum Mozilla in inglese (mozillaZine).

Poi le mie peregrinazioni sono proseguite e, forse - ripeto, sottolineo e ribadisco, - forse qualcosa è successo ...

In un sito di cui ho perso traccia, tra i tanti che ho con foga visitato, ho visto che il problema poteva derivare dalla chiave security.enterprise_roots.enabled, raggiungibile da "about:config".

Praticamente sembrerebbe che questa proprietà/chiave (vorrete scusarmi per l'imprecisione dei termini), forzi l'acquisizione dei certificati da una certa root di Windows laddove sia impostata a "true", pure influendo pure sul modulo "master password".
Ebbene, nel mio caso era esattamente impostata a "true".
Ulteriore problema (... potevo non averne?!  :sbat: ): la chiave/proprietà era oltretutto bloccata ("locked")!

Quindi:
  • dovevo sbloccare la chiave;
  • modificare il valore da true a false.

Sempre seguendo le istruzioni del sito di cui, mi scuso e dispiaccio, adesso non ritrovo più il collegamento, sono andato alla caccia di un file con estensione ".cfg" all'interno della cartella "C:\Programmi\Mozilla Firefox".
Trovato il file (con nome davvero strano: kl_config_62fbb8f7_c917_4cf7_957a_aad2b8fa768c.cfg) l'ho aperto attraverso il blocco note di Windows e, sorpresa, dentro ho rinvenuto esattamente questo:
Citazione
// kl_config_62fbb8f7_c917_4cf7_957a_aad2b8fa768c.cfg
lockPref("security.enterprise_roots.enabled", true);

Inutile dire che il tentativo sul posto di modificare da true a false il valore della chiave non andava a buon fine in nessuna maniera (all'atto del salvataggio venivo indirizzato in tutt'altra cartella, senza alcuna possibilità di sovrascrivere il file contenuto nella directory), sebbene Firefox fosse chiuso.

Altro tentativo: con Firefox chiuso, ho rinominato il file con estensione ".cfg" in "nomefile.cfg.OLD".
Appena lanciato Firefox il file in questione veniva ricreato esattamente come prima e con la chiave sempre valorizzata a "true".

Quindi ho deciso l'ultimo assalto:
  • ho chiuso Firefox;
  • ho prelevato il file con estensione "*.cfg" (kl_config_62fbb8f7_c917_4cf7_957a_aad2b8fa768c.cfg);
  • ho creato una copia (di emergenza-bakcup) del file originale "*.cfg";
  • ho aperto il file "*.cfg" con il blocco note di Windows e cambiato il valore da true e false, quindi salvato senza problemi il file;
  • il file "*.cfg" così da me modificato è stato incollato dentro "C:\Programmi\Mozilla Firefox", sovrascrivendo quello già esistente.

La chiave "security.enterprise_roots.enabled" risulta ancora "locked", ma il valore è impostato su "false" e la finestra per l'inserimento della master password (o password principale) non compare "a sproposito", ossia sempre e comunque all'apertura di Firefox.
Almeno per il momento ... (spero!).

GRAZIE ancora per l'attenzione e per ogni ulteriore suggerimento/indicazione che dovesse arrivare.

Offline Iceberg

  • Moderatore
  • Post: 8068
Grazie di aver riportato tutto l'iter per arrivare alla soluzione.
Resterebbe da scoprire chi ha modificato e bloccato il parametro. Ce ne sono vari di soggetti che modificano e bloccano questo parametro, ma al file danno un nome significativo che fa capire chi lo ha creato.

Firefox di suo non legge questo file, dovresti avere anche un file local-settings.js
https://support.mozilla.org/it/questions/1160596

(kl_config... K L = Kaspersky Lab? tra parentesi perché è un'idea senza alcuna fonte)

Offline markinson

  • Post: 45
Grazie di aver riportato tutto l'iter per arrivare alla soluzione.
Resterebbe da scoprire chi ha modificato e bloccato il parametro. Ce ne sono vari di soggetti che modificano e bloccano questo parametro, ma al file danno un nome significativo che fa capire chi lo ha creato.

[...]

(kl_config... K L = Kaspersky Lab? tra parentesi perché è un'idea senza alcuna fonte)

Sono io a dovervi e doverti, in modo particolare, ringraziare per l'attenzione e il tempo dedicato.
Nonostante la comprovata validità dell'antivirus Kaspersky, seppure in versione free, devo ammettere che bisogna prenderci un po' di confidenza e, soprattutto, accettare la sua maniacale attenzione a monitorare, intervenire e alla fine impedire silenziosamente ogni "cambiamento profondo" oppure "modifica reputata sensibile", sia al sistema operativo (gli aggiornamenti cumulativi mensili di Windows impongono di disattivare temporaneamente la protezione residente per essere portati a termine) sia alle varie impostazioni qua e là sparse.

Tutta questa mia pappardella (scusatemi!) per dire che la tesi di Iceberg mi trova molto d'accordo.
Cioè, i miei primi sospetti si erano indirizzati su due "scudi protettivi" di Kaspersky:
  • l'addon Kaspersky Protection (ma non ero molto convito di questo, considerato che ho anche riavviato Firefox in modalità provvisoria-safe), con la finestra pop up della password principale di nuovo inesorabilmente lì;
  • la protezione per le connessioni cryptate (quantunque disattivata, certi servizi "profondi" restano residenti e ... non intendono cedere il passo, secondo me).

Aggiungo: in altri elaboratori con configurazioni pressoché simili, anche se non identiche (altri antivirus, ad esempio), il problema riscontrato su questa macchina non si è presentato.

Quindi, confortato dal suggerimento-ipotesi di Iceberg, ho deciso un ultimo sforzo per questa giornata e, via Google, ho cercato di orientare la ricerca, sino a raggiungere il seguente thread: Kaspersky certificate not verified
Qui si parla proprio di certificati verificati o meno (il punto di partenza del percorso nella ricercata presente soluzione) e proprio della stringa "security.enterprise_roots.enabled".

Magari a mente lucida farò qualche ulteriore verifica, compatibilmente con le mie enormi lacune di inglese ...

Grazie ancora della pazienza, a tutti!
Rinnovo: per il momento, il problema della comparsa a prescindere, all'avvio di Firefox, della finestra di inserimento della "master password" sembra essere superato ... sembra (la prudenza non è mai troppa!).
 :roll: :wink:

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23646
    • Mozilla Italia
Quindi in pratica è Kaspersky che forza quella impostazione in about:config? Questa cosa è interessantissima.
Grazie anche da parte mia per aver riportato la soluzione ;)

Offline MultiScorp

  • Post: 4
La chiave "security.enterprise_roots.enabled" risulta ancora "locked", ma il valore è impostato su "false" e la finestra per l'inserimento della master password (o password principale) non compare "a sproposito", ossia sempre e comunque all'apertura di Firefox.
Almeno per il momento ... (spero!).

CIao
Non mi sembra una soluzione ottimale.
Se non ho inteso male quella voce - security.enterprise_roots.enabled - nel registro di configurazione di Mozilla, serve a forzare Firefox (e Thunderbird) a utilizzare i certificati di sistema e non quelli mantenuti da Firefox.
Ora quale dovrebbe essere il problema della "master password" che viene richiesta all'avvio? Secondo me (ho anch'io il tuo problema) questo è dovuto al fatto che - probabilmente con un recentissimo aggiornamento di Kaspersky - l'AV vuole forzare questa cosa per poter controllare anche il traffico web che avviene tramite connessione sicura SSL, per questo ti chiede l'accesso alla master password.

Però sicuramente è l'AV che ha introdotto questo "problema", ma la tua soluzione non mi sembra ottimale.

In teoria però questo non dovrebbe accadere quando uno ha settato "Non esaminare le connessioni crittografate" nelle impostazioni dell'AV (Avanzate - Rete)... il fatto che da qualche giorno accada è "strano".

Offline Iceberg

  • Moderatore
  • Post: 8068
Non è una soluzione ottimale ma se non si trova l'impostazione dell'antivirus che la gestisce è comunque una soluzione.
Riuscite a trovarla questa impostazione? Ammesso che ci sia.

C'è stata la proposta di mettere questo parametro a true per impostazione predefinita.
https://bugzilla.mozilla.org/show_bug.cgi?id=1314010
Proposta bocciata, almeno fino ad ora.

Offline markinson

  • Post: 45
Quindi in pratica è Kaspersky che forza quella impostazione in about:config? Questa cosa è interessantissima.
Grazie anche da parte mia per aver riportato la soluzione ;)

Non ho competenze sufficienti per poter puntare il dito con certezza su Kaspersky, però credo proprio che tutto sia dipeso da un recente aggiornamento del prodotto Kaspersky installato sulla mia macchina.
Questo aggiornamento è sicuramente intervenuto (almeno per mio conto) dopo venerdì 7 dicembre. Sono così sicuro perché, nei vari tentativi eseguiti, avevo ripristinato l'elaboratore (mediante un'immagine realizzata con Macrium Reflect Free Edition) proprio a venerdì 7 dicembre e, nell'immediato, la "master password" non veniva richiesta all'apertura di Firefox.
Terminato l'aggiornamento del mio  Kaspersky Free (adesso passato dalla versione 19.0.0.1088ab alla versione 19.0.0.1088d), sono ripresi i problemi, ossia la richiesta della "master password" sempre e comunque all'apertura di Firefox.
Almeno questa la sommaria ricostruzione che posso a posteriori fornire.

Però sicuramente è l'AV che ha introdotto questo "problema", ma la tua soluzione non mi sembra ottimale.

Non credo nemmeno io che sia la soluzione (ottimale) e su questo mi trovo poi d'accordo con Iceberg.
Non è una soluzione ottimale ma se non si trova l'impostazione dell'antivirus che la gestisce è comunque una soluzione.

Diciamo che forse è stato utile essere risaliti alla genesi del comportamento anomalo (o sopravvenuto, che dir si voglia) di Firefox.
Almeno, mettiamola così, per escludere che questa strana quanto ingiustificata richiesta della master password, come contestualizzata, finisse per discendere dalla presenza di qualche sgradito ospite tipo malware o peggio.

Sulla soluzione e dove poter intervenire ...
... se non si trova l'impostazione dell'antivirus che la gestisce è comunque una soluzione.
Riuscite a trovarla questa impostazione? Ammesso che ci sia.
In teoria però questo non dovrebbe accadere quando uno ha settato "Non esaminare le connessioni crittografate" nelle impostazioni dell'AV (Avanzate - Rete)... il fatto che da qualche giorno accada è "strano".

Assicuro che, da tempo e per altri problemi con alcuni siti, ho dovuto disattivare la funzione di Kaspersky che controlla le connessioni criptate.
Nella mia versione (free) dell'antivirus ho selezionato infatti l'opzione "Do not scan encrypted connections" nella sezione "Network settings - Encrypted connections scanning".

La faccenda ulteriormente curiosa è che prelevato il (mio) file kl_config_62fbb8f7_c917_4cf7_957a_aad2b8fa768c.cfg con dentro l'istruzione "true" per la preferenza security.enterprise_roots.enabled, una volta da me apportata la modifica con un editor (da "true" a "false"), il copia e incolla del file (da me) modificato nella cartella di Mozilla Firefox è stata un'operazione indolore e Kaspersky (ammesso che sia lui) nulla ha eccepito.
Diversamente, eliminando il file oppure rinominandolo, Kasperky (sempre ammesso che sia lui) lo ricrea.
Insomma: se non lo trova, lo riproduce; se lo trova, quantunque alterato (da me), lo lascia lì com'è.

Se dovessi avere modo e tempo per qualche tentativo in proprosito, tornerò a riaffacciarmi qui sul forum.

GRAZIE ancora a tutti per la disponibilità!  :)

Offline Iceberg

  • Moderatore
  • Post: 8068
Diversamente, eliminando il file oppure rinominandolo, Kasperky (sempre ammesso che sia lui) lo ricrea.
Insomma: se non lo trova, lo riproduce; se lo trova, quantunque alterato (da me), lo lascia lì com'è.

Evidentemente controlla che il file sia presente ma non controlla il contenuto. In questo caso suona bene ma se davvero un file creato da un antivirus può essere così facilmente manipolato non suona poi tanto bene.

Offline MultiScorp

  • Post: 4
Vi confermo che la problematica riguarda proprio Kaspersky, così come indicato sul loro forum

https://forum.kaspersky.com/index.php?/topic/404209-firefox-and-thunderbird-always-require-in-startup-the-master-password%EF%BB%BF/

A quanto si legge è stata "introdotta" una nuova funzionalità nella versione (d) rilasciata da pochissimo, che crea questo file in Thunderbird e Firefox per forzare quella configurazione di cui parlavamo.
Poi non si sa per quale ragione, ma Kaspersky forza l'immissione (un bug?) della master password (se configurata) all'avvio dell'applicazione se si usa lo store dei certificati del SO e non quello di Mozilla (quindi valore "true")... se invece si configura quella funzionalità in modo tale da utilizzare lo store dei certificati di Mozilla, il problema scompare... se invece si disattiva la funzionalità - credo per un bug- il problema persiste, perché quel file non viene cancellato.


Effettivamente la cosa è un po' strana.
« Ultima modifica: 13 Dicembre 2018 13:58:48 da MultiScorp »

0 Utenti e 1 Visitatore stanno visualizzando questo topic.