Notizie: scarica ora l'ultima versione disponibile di Thunderbird!

Autore Topic: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare  (Letto 1203 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23137
    • Mozilla Italia
Ho appena aperto un bug per questa cosa strana

https://bugzilla.mozilla.org/show_bug.cgi?id=1423506

Offline michro

  • Moderatore
  • Post: 19225
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #1 il: 06 Dicembre 2017 10:20:28 »
Io anche sulla 57 se metto a false quella preferenza continuo a vedere le icone (favicon) accanto al nome del segnalibro sulla barra dei segnalibri.
Modificata la preferenza e riavviato ma le icone sono sempre lì. Sbaglio qualcosa?

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23137
    • Mozilla Italia
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #2 il: 06 Dicembre 2017 10:25:55 »
Prova anche browser.chrome.site_icons

Offline michro

  • Moderatore
  • Post: 19225
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #3 il: 06 Dicembre 2017 10:30:13 »
Ma devo modificare sia browser.chrome.favicons che browser.chrome.site_icons ?

Edit: personalizzate/modificate entrambe, riavviato e sono ancora lì
« Ultima modifica: 06 Dicembre 2017 10:37:13 da michro »

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23137
    • Mozilla Italia
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #4 il: 06 Dicembre 2017 10:40:56 »
Chiudi il browser, rimuovi il file favicon.sqlite dalla cartella del profilo e vedi se cambia qualcosa.

Offline michro

  • Moderatore
  • Post: 19225
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #5 il: 06 Dicembre 2017 10:46:28 »
Sono sempre lì... vedi immagine

Edit: l'unica variazione è che adesso nella cartella del profilo mi ritrovo oltre al file favicon.sqlite
anche
favicon.sqlite-shm
favicon.sqlite-wal
che non so cosa siano???

« Ultima modifica: 06 Dicembre 2017 11:01:04 da michro »

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23137
    • Mozilla Italia
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #6 il: 06 Dicembre 2017 11:00:15 »
Chiudi Firefox e cancella tutti file favicons.*

@Michro: guarda che quelle non sono le favicons :)
Le favicons sono le icone dei siti web... quelle che hai tu sono quelle generiche di Firefox, e quindi la preferenza funziona :)

Offline michro

  • Moderatore
  • Post: 19225
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #7 il: 06 Dicembre 2017 11:08:37 »
Aperto la cartella del profilo da Risoluzione dei problemi e chiuso Firefox: i due file "favicon.sqlite-shm" e "favicon.sqlite-wal" erano spariti ed era rimasto un nuovo "favicon.sqlite".
L'unico risultato è che le favicon si erano tutte ingrigite e si erano trasformate in mappamondi perdendo le favicon colorate e originali dei siti (a parte le cartelle che sempre grigie sono) come da mia precedente immagine .
Anche se visitavo i siti, rimanevano grigie.
 


Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23137
    • Mozilla Italia
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #8 il: 06 Dicembre 2017 11:14:05 »
E quindi la preferenza funziona magnificamente: io detesto le icone dei siti e preferisco i mappamondi grigi :)

Offline michro

  • Moderatore
  • Post: 19225
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #9 il: 06 Dicembre 2017 12:28:36 »
Probabilmente avevo frainteso. Pensavo ingenuamente che volessi far sparire completamente l'icona davanti al nome del segnalibro sulla barra...
Se il tuo scopo era quello di ottenere i mappamondi grigi al posto delle favicon colorate modificando la preferenza browser.chrome.favicons, ho provato adesso sulla beta 58b9.
Dopo aver modificato la preferenza, ho spostato il file "favicon.sqlite" sulla scrivania e riavviato Firefox: le favicon si trasformano in mappamondi grigi (che pena).
Ripristinata la preferenza, rimesso il mio file "favicon.sqlite" originale e sono tornati i miei amati colori ;-)

Quindi, se ho capito correttamente, nel mio caso la sola modifica della preferenza in about:config non ha effetto a meno che non si elimini il file "favicon.sqlite" facendolo ricreare.

Era la conferma che volevi avere?

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23137
    • Mozilla Italia
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #10 il: 06 Dicembre 2017 12:40:09 »
No, il problema mio (leggi nel bug report) è che anche se si elimina il file favicons.sqlite, alcune icone rimangono.

Ti dico di più: sono andato a scandagliare il favicons.sqlite anche con il SQLite Browser (programma che legge nativamente il database sqlite): ho provato a svuotare proprio le tabelle, eliminando tutti i riferimenti a quegli URL. Risultato: se lo rimetto dov'era prima, il database riacquista i riferimenti a questi URL (non più di tre o quattro).

Significa che queste icone vengono da qualche altra parte. Infatti MaK che ha risposto dentro il bug chiede (da quanto ho capito) se per caso queste icone non provengono dai siti in homepage (che ovviamente ho disattivato).

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23137
    • Mozilla Italia
Re: In Fx 58b9 la preferenza browser.chrome.favicons non sembra funzionare
« Risposta #11 il: 13 Dicembre 2017 08:24:31 »
Il bug è stato confermato e risolto nell'ultima beta della 58, quindi non sarà presente nella prossima stabile.

0 Utenti e 1 Visitatore stanno visualizzando questo topic.