Notizie: scarica ora l'ultima versione disponibile di SeaMonkey!

Autore Topic: Estensioni obsolete con nuova versione di Firefox  (Letto 3561 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline p060477

  • Post: 1684
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #15 il: 21 Agosto 2017 07:42:20 »

speriamo allora che qualcuno riesca a creare una sorta di profile switchers add on compatibile con i nuovi dettami di ff 57...
..ma lo so che chi vive sperando ..muore...etcc...

quando lo affronterai puoi mettere un link qui cosi' possiamo sapere di cosa si tratta..
mi hai molto incuriosito..
se sei terrorizzato te..figurati io...
:(

Offline miki64

  • Moderatore
  • Post: 33072
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #16 il: 21 Agosto 2017 09:05:51 »
Quando uscì Firefox 4 che rompeva decisamente col passato a livello di interfaccia ma soprattutto di funzionalità, Mozilla creò un'apposita estensione per semplificare il passaggio dalle vecchie alle nuove versioni, ricordi?
Stavolta non c'è stata nessuna facilitazione, se non quella di fornire agli sviluppatori tempo sufficiente per adeguarsi (il che è già sufficiente e lodabile, rispetto a delle forzature violente tipo quelle di Microsoft in passato).
Il mio grande timore è che questa politica di Mozilla coinvolga - per coerenza o convenienza - qualcos'altro che tu non utilizzi, quindi puoi stare tranquillo.

Online deckard

  • Post: 3239
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #17 il: 21 Agosto 2017 14:40:50 »
Firefox 55 and Selenium IDE
Official Selenium Blog -- 9 Agosto 2017

Selenium IDE Firefox add-on end of live
By Martin Brinkmann on August 21, 2017 in Firefox - Ghacks.net

Anche Self Destructing Cookies potrebbe e dovrebbe aver raggiunto la fine del ciclo vitale.
Citazione
About this Add-on
This add-on is no longer maintained. It is incompatible with Firefox 55+ and this will never change. Also, it will not be rewritten as a WebExtension.

To say that it's been an interesting 5 years would be an understatement. May your cookies always self-destruct. Godspeed.

E quest'ultima per me è una pessima notizia. Poi ci si chiede perché io abbandoni Firefox.

Offline p060477

  • Post: 1684
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #18 il: 21 Agosto 2017 16:20:18 »
..il panorama si fa sempre piu' buio e tetro..come cantava il grande Guccini ..
forse Miki ti riferivi al -pinguino-..??
https://en.wikipedia.org/wiki/Tux
:(
« Ultima modifica: 21 Agosto 2017 16:23:49 da p060477 »

Offline flod

  • Amministratore
  • Post: 15058
    • http://www.flod.org
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #19 il: 21 Agosto 2017 18:05:19 »
Quando uscì Firefox 4 che rompeva decisamente col passato a livello di interfaccia ma soprattutto di funzionalità, Mozilla creò un'apposita estensione per semplificare il passaggio dalle vecchie alle nuove versioni, ricordi?
Uh? O non ho capito di cosa parli, oppure ho rimosso (ed è raro considerato come funziona il mio cervello).

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 24582
    • Mozilla Italia
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #20 il: 21 Agosto 2017 18:15:26 »
Add-on Compatibiliy Reporter?

Offline miki64

  • Moderatore
  • Post: 33072
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #21 il: 22 Agosto 2017 07:55:40 »
Sì, bravo Underpass!  :D

EDIT
@p060477: no, non mi riferivo a Linux, c'è una citazione nella mia emoticon che solo certi appassionati potranno cogliere, tu non preoccuparti, ti assicuro che non corri questo rischio.   :)
« Ultima modifica: 22 Agosto 2017 07:57:21 da miki64 »

Offline gabryele

  • Post: 898
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #22 il: 19 Novembre 2017 11:19:11 »
C'è la possibilità di utilizzare componenti aggiuntivi Legacy in Firefox Nightly 57 (ignoro se ci sarà nelle versioni beta e stabili di Firefox 57 o nelle successive Nighlies) impostando la preferenza extensions.legacy.enabled a true.

ma questa preferenza extensions.legacy.enabled permette di far funzionare qualche estensione obsoleta o non ci provo neanche?

Offline trekfan1

  • Post: 609
    • http://www.startrekitalia.net
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #23 il: 19 Novembre 2017 11:28:07 »
Funzionava nella nightly, dalla beta NO, quell'opzione è "deprecata"

Offline Iceberg

  • Moderatore
  • Post: 8478
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #24 il: 19 Novembre 2017 11:29:39 »
Pare che con quella preferenza true, al primo avvio di Firefox 57 dopo il controllo delle estensioni talvolta quelle legacy vengono messe in disattivazione ma non disattivate subito, solo dopo il primo riavvio spariscono per sempre.
Credo che hai già sperimentato qualcosa del genere ed è capitato anche a me. Dovrebbe riguardare le estensioni che richiedono il riavvio, capita molto di rado, dura poco. Per risponderti non vale la pena provarci.

Offline p060477

  • Post: 1684
Re: Estensioni obsolete con nuova versione di Firefox
« Risposta #25 il: 03 Dicembre 2017 07:01:27 »
grazie Iceberg..così non ci perdo neppure tempo e pazienza..
;)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.