Notizie: scarica ora l'ultima versione disponibile di SeaMonkey!

Autore Topic: Problemi mail: forse un bug ?  (Letto 1692 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline francesco bat

  • Post: 162
    • La Grotta del Pipistrello
Problemi mail: forse un bug ?
« il: 20 Gennaio 2016 00:06:08 »
Ciao a tutti.
Volevo segnalare questa problematica riscontrata da subito dopo aver aggiornato alla versione 2.39 gia da un bel pò di tempo.
Il problema riscontrato è il blocco totale di Seamonkey dopo avere avviato la seconda volta la finestra delle mail.
Il problema è pesantemente marcato durante l'utilizzo di un altro tema oppure con alcune estensioni attive tipo Custombuttons, ma posso garantire che spesso crasha tutto alla seconda apertura della finestra mail spesso anche con estensioni disabilitate.
Per esempio: ricevo una mail, apro per la prima volta la finestra delle mails ed è tutt'ok; chiudo riapro la finestra delle mail e si blocca il programma che non risponde e devo terminarlo con la forza.
Il problema è stato risolto con l'estensione "firetray" che alla chiusura sulla finestra della mail non la chiude veramente ma la inserisce nella traybar del pannello del sistema operativo e così può essere riaperto senza problemi, ma se viene totalmente chiuso direttamente dal menù, alla seconda apertura il blocco è garantito.
Spero di essere stato chiaro.
Ciao
Francesco bat

Offline iacchi

  • Amministratore
  • Post: 6303
    • iacchiblog
Re: Problemi mail: forse un bug ?
« Risposta #1 il: 20 Gennaio 2016 00:42:04 »
Chiaro e' chiaro. Provero' a fare un po' di prove e vedere se accade anche a me. Visto che ti capita cosi' spesso: se puoi/vuoi puoi creare un nuovo profilo, magari aggiungerci un account imap cosi' stai tranquillo, e fare un po' di prove col nuovo profilo? Giusto per conferma. In alternativa, puoi lanciare seamonkey da console un po' di volte, cosi' quando crasha c'e' un log scritto di che succede?

Offline francesco bat

  • Post: 162
    • La Grotta del Pipistrello
Re: Problemi mail: forse un bug ?
« Risposta #2 il: 20 Gennaio 2016 01:00:08 »
Chiaro e' chiaro. Provero' a fare un po' di prove e vedere se accade anche a me. Visto che ti capita cosi' spesso: se puoi/vuoi puoi creare un nuovo profilo, magari aggiungerci un account imap cosi' stai tranquillo, e fare un po' di prove col nuovo profilo? Giusto per conferma. In alternativa, puoi lanciare seamonkey da console un po' di volte, cosi' quando crasha c'e' un log scritto di che succede?

Purtroppo il blocco è proprio totale e la finestra di SeaMonkey non risponde proprio più.
Ho provato a vedere i logs ma non ho trovato niente forse perchè non riesce neanche a crearne uno.
Però penso che essendo il problema alla seconda apertura, un messaggio di errore potrebbe essere già creato all'apertura della finestra della mail la prima volta o alla chiusura della stessa.
Magari potrei essere di aiuto a individuare l'anomalia ed eventualmente correggerla, mi farebbe piacere sia per me che per il miglioramento del programma  :)
Ciao
Francesco bat

Offline iacchi

  • Amministratore
  • Post: 6303
    • iacchiblog
Re: Problemi mail: forse un bug ?
« Risposta #3 il: 20 Gennaio 2016 01:03:59 »
Giusto per completezza: usi una versione di SeaMonkey scaricata con i repo della tua distribuzione, oppure la build ufficiale scaricata dal sito di SeaMonkey?

Offline francesco bat

  • Post: 162
    • La Grotta del Pipistrello
Re: Problemi mail: forse un bug ?
« Risposta #4 il: 20 Gennaio 2016 01:06:19 »
Giusto per completezza: usi una versione di SeaMonkey scaricata con i repo della tua distribuzione, oppure la build ufficiale scaricata dal sito di SeaMonkey?

No sto usando la versione scaricata dal repository del gestore pacchetti.

Offline iacchi

  • Amministratore
  • Post: 6303
    • iacchiblog
Re: Problemi mail: forse un bug ?
« Risposta #5 il: 20 Gennaio 2016 01:25:35 »
Potresti fare una prova anche con la build ufficiale? Il profilo resta lo stesso, basta che scarichi il file zip, lo scompatti e avvii il programma da li'. Giusto per essere sicuri che non sia un problema della build dei repo.

Offline francesco bat

  • Post: 162
    • La Grotta del Pipistrello
Re: Problemi mail: forse un bug ?
« Risposta #6 il: 20 Gennaio 2016 01:34:33 »
Siccome mi avevi fatto venire un dubbio, ho scaricato ora il file, scompattato ed eseguito e stesso problema.
Testato invece seamonkey da utente nuovo e funziona tutto correttamente, ma la mail non ho estensioni e mail configurata li.
Ho fatto un test scaricando "Custom Buttons", e con l'estensione attivata lo stesso non crasha.
Quindi il problema è nella mia utenza, ma non è realmente chiaro il problema da dove proviene, anche se con "Custom buttons" attivato il crash è assicurato al 100% al secondo avvio della mail; in caso non è attivo, quasi sempre crasha lo stesso ma a volte funziona normale e non si spiega perchè.  :|

Offline iacchi

  • Amministratore
  • Post: 6303
    • iacchiblog
Re: Problemi mail: forse un bug ?
« Risposta #7 il: 20 Gennaio 2016 01:58:49 »
E se provi a installare Custom buttons nel profilo nuovo? Crasha? Perche' in caso vuol dire che quell'estensione e' il problema e in qualche modo ha incriccato dei file nel tuo profilo al punto tale che anche se e' disattivata il programma crasha comunque.

Offline francesco bat

  • Post: 162
    • La Grotta del Pipistrello
Re: Problemi mail: forse un bug ?
« Risposta #8 il: 20 Gennaio 2016 02:02:54 »
E se provi a installare Custom buttons nel profilo nuovo? Crasha? Perche' in caso vuol dire che quell'estensione e' il problema e in qualche modo ha incriccato dei file nel tuo profilo al punto tale che anche se e' disattivata il programma crasha comunque.

Provato ad installare custom buttons nel nuovo profilo, come ho descritto prima, e funziona tutto bene e non si blocca; solo che la mail non è configurata li e non so se questo ha fatto la differenza.
Invece nel mio profilo vecchio se disabilito custom buttons, spesso va bene ma non sempre perchè a volte crasha lo stesso dalla seconda apertura della mail e non si riesce a capire il perchè.

Offline iacchi

  • Amministratore
  • Post: 6303
    • iacchiblog
Re: Problemi mail: forse un bug ?
« Risposta #9 il: 20 Gennaio 2016 02:22:43 »
Non saprei che dire allora, a parte il fatto che il problema e' del tuo profilo e non del programma in generale. Quanto e' vecchio il profilo? Puo' essere che dopo anni, versioni diverse e "pacioccamenti" con estensioni qualcosa si incricchi. Anche il mio profilo standard, che ne ha viste di cotte e di crude, qualche problemino ce l'ha, pero' mi sta troppa fatica crearne uno nuovo e riportarci sopra i dati, quindi mi tengo i problemini :P Il tuo problema e' decisamente piu' grosso pero', magari potresti pensare di fare un trapianto di profilo...

Offline francesco bat

  • Post: 162
    • La Grotta del Pipistrello
Re: Problemi mail: forse un bug ?
« Risposta #10 il: 20 Gennaio 2016 17:25:37 »
Non saprei che dire allora, a parte il fatto che il problema e' del tuo profilo e non del programma in generale. Quanto e' vecchio il profilo? Puo' essere che dopo anni, versioni diverse e "pacioccamenti" con estensioni qualcosa si incricchi. Anche il mio profilo standard, che ne ha viste di cotte e di crude, qualche problemino ce l'ha, pero' mi sta troppa fatica crearne uno nuovo e riportarci sopra i dati, quindi mi tengo i problemini :P Il tuo problema e' decisamente piu' grosso pero', magari potresti pensare di fare un trapianto di profilo...

Individuato il problema o meglio l'estensione che crea un conflitto  8)
Ora chiedo lumi sulla soluzione oppure forse andrebbe segnalato allo staff.
L'estensione che crea il problema (ed è anche molto importante) è Lightbird che permette l'esecuzione di Lightning su SeaMonkey.
Non tenendo attivo Custom Buttons non da problemi, ma alcune volte posso garantire che è capitato lo stesso il crash.
Ne sono venuto a capo non avviando SeaMonkey con le estensioni disattivate (siccome lo avevo già fatto ed era tutt'ok) e siccome non si può comprendere il reale colpevole, ma disattivando tutte le estensioni meno che Custoom Buttons e ho visto che funzionava tutto bene.
Successivamente ho cominciato a riattivare tutte le estensioni una alla volta, testando di continuo le varie aperture della finestra mail e non ci è stato alcun problema, come ho avviato Lightbird ci è stato il blocco con il test  8)
Ciao
Francesco bat
« Ultima modifica: 20 Gennaio 2016 17:30:54 da francesco bat »

Offline Godai71

  • Moderatore
  • Post: 4153
    • The Walking Shadow
Re: Problemi mail: forse un bug ?
« Risposta #11 il: 20 Gennaio 2016 17:57:05 »
Utilizzo Lightbird e non riscontro il problema che lamenti.

Qualche volta (una al mese) quando chiudo  SeaMonkey non si chiude, ma non mi si è mai bloccato.
Probabilmente si tratta di un conflitto tra LightBird e Custom Buttons.

Offline francesco bat

  • Post: 162
    • La Grotta del Pipistrello
Re: Problemi mail: forse un bug ?
« Risposta #12 il: 20 Gennaio 2016 18:02:24 »
Utilizzo Lightbird e non riscontro il problema che lamenti.

Qualche volta (una al mese) quando chiudo  SeaMonkey non si chiude, ma non mi si è mai bloccato.
Probabilmente si tratta di un conflitto tra LightBird e Custom Buttons.

Io penso che non è solo un conflitto con Custom Buttons  ma anche con altre estensioni; ad esempio tempo fa mi si bloccò molte volte anche con dei stili attivi con Stilysh e avevo custom buttons disattivato.
Infatti da quell'esempio capì che il problema non era custom buttons anche se con lui il problema è molto più marcato.
Ciao
Francesco bat

Offline iacchi

  • Amministratore
  • Post: 6303
    • iacchiblog
Re: Problemi mail: forse un bug ?
« Risposta #13 il: 21 Gennaio 2016 01:45:40 »
In ogni caso Lightbird non serve per avere Lightning su SeaMonkey, serve solo per averlo come componente a se' stante. Come dice Godai71, e' probabile che sia una combinazione di estensioni che causa il problema. A meno che non ti serva vedere veramente Lightning come un componente a se' stante, io mi terrei Lightning dentro il componente di posta e disinstallerei Lightbird.

Offline francesco bat

  • Post: 162
    • La Grotta del Pipistrello
Re: Problemi mail: forse un bug ?
« Risposta #14 il: 21 Gennaio 2016 01:55:13 »
In ogni caso Lightbird non serve per avere Lightning su SeaMonkey, serve solo per averlo come componente a se' stante. Come dice Godai71, e' probabile che sia una combinazione di estensioni che causa il problema. A meno che non ti serva vedere veramente Lightning come un componente a se' stante, io mi terrei Lightning dentro il componente di posta e disinstallerei Lightbird.

Grazie mille !
Ora me ne sono accorto.
Siccome su thunderbird ci sono le iconcine in alto a destra per accedere al calendario, pensavo che su seamonkey non era possibile se non solo con l'aggiunta di lightbird (forse perchè avevo scaricato seamonkey da pochissimo tempo e non lo avevo ancora capito bene).
In questo momento ho potuto capire che è possibile accedere al calendario dall'apposito menù.
Adesso disattivando lightbird sto aprendo e chiudendo la mail senza problemi.
Testo questa situazione per un pò e vedo se ci sono problemi.
Nel frattempo spero che una prossima versione di lightbird corregga questo problema (se è lui veramente la causa) perchè comunque mi piace alternare anche un poco ogni tanto con la vecchia interfaccia di Sunbird  :)
Ciao
Francesco bat

0 Utenti e 1 Visitatore stanno visualizzando questo topic.