Notizie: è uscita la versione 68 di Thunderbird! Scopri tutte le novità!

Autore Topic: Rimuovere elenco Pocket  (Letto 2184 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Ronnie91

  • Post: 3518
Rimuovere elenco Pocket
« il: 11 Novembre 2015 06:49:52 »
Ciao a tutti, è possibile rimuovere elenco Pocket dalla Barra dei segnalibri?


Firefox 43 Beta 2, Pocket disattivato da about:config.
« Ultima modifica: 11 Novembre 2015 06:52:56 da Ronnie91 »

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23137
    • Mozilla Italia
Re: Rimuovere elenco Pocket
« Risposta #1 il: 11 Novembre 2015 08:27:38 »
Strano, io ho disattivato Pocket da about:config e quella voce non mi compare.

Comunque, in userchrome.css:

Codice: [Seleziona]
#menu_pocket, #menu_pocketSeparator, #panelMenu_pocket, #BMB_pocket, #BMB_pocketSeparator { display:none !important; }
#context-savelinktopocket, #context-pocket { display:none!important; }
« Ultima modifica: 11 Novembre 2015 08:30:27 da Underpass »

Offline Ronnie91

  • Post: 3518
Re: Rimuovere elenco Pocket
« Risposta #2 il: 11 Novembre 2015 08:56:02 »
Grazie Underpass, in about:config basta mettere a false questo parametro: browser.pocket.enabled, giusto?

P.S. Ho provato con un profilo pulito, adesso provo con un altro.
P.P.S. Non bisogna usare il file userContent?

EDIT: Con un nuovo profilo non riscontravo il problema, quindi ho provato a ripristinare tutti i parametri modificati relativi a Pocket in about:config ed ho risolto anche nel profilo dove avevo il problema. Grazie mille ancora e scusate. Buona giornata!
« Ultima modifica: 11 Novembre 2015 09:10:11 da Ronnie91 »

Offline michro

  • Moderatore
  • Post: 19223
Re: Rimuovere elenco Pocket
« Risposta #3 il: 11 Novembre 2015 11:59:21 »
Nell'articolo https://support.mozilla.org/it/kb/disattivare-pocket-firefox gli en-US hanno deciso momentaneamente di rendere non visibile questa procedura (non so quale sia il motivo ma riporto):

Codice: [Seleziona]
Per disattivare il componente aggiuntivo predefinito Pocket:
# Aprire una nuova scheda del browser e collegarsi con la pagina [http://about:config about:config].
# Leggere l'avviso e fare clic su {button Farò attenzione, prometto}.
# Digitare '''browser.pocket.enabled'''  nel campo "Cerca:" (o copiarlo e incollarlo da qui).
# Fare clic con il tasto destro del mouse sulla linea che include in valore '''True''' e selezionare {menu Imposta} dal menu delle opzioni. Il valore verrà modificato in '''False'''.
# Riavviare il browser.

Nei menu non dovrebbero più essere visualizzate le opzioni del componente aggiuntivo Pocket.

Per riattivare questa funzione, seguire questa procedura:
# Aprire una nuova scheda del browser e collegarsi con la pagina [http://about:config about:config].
# Leggere l'avviso e fare clic su {button Farò attenzione, prometto}.
# Digitare '''browser.pocket.enabled'''  nel campo "Cerca:" (o copiarlo e incollarlo da qui).
# Fare clic con il tasto destro del mouse sulla linea che include in valore '''False''' e selezionare {menu Imposta} dal menu delle opzioni. Il valore verrà modificato in '''True'''.
# Riavviare il browser.

Offline Plink

  • Post: 33
Re: Rimuovere elenco Pocket
« Risposta #4 il: 01 Ottobre 2016 09:46:12 »
Salve.

Ho lo stesso problema con FF 45.3.0 esr su WXP ma la procedura non mi funziona.
Ho verificato più volte che in "about:config" sia presente il parametro "browser.pocket.enabled" e che sia impostato su "false"... e ho pure chiuso e riavviato più volte Firefox, ma... nei segnalibri continuo a visualizzare la cartella "Pocket".

Come posso risolvere definitivamente ?

Grazie

Aggiunta:
Ho provato anche ad aggiungere "extensions.pocket.enabled" su "False", ma niente...  :(

Aggiunta 2:
Ok...
Ho risolto con "userchrome.css" come suggerito da Underpass... Grazie. :wink:
Scusate se non l'ho provato subito, ma sembrava una soluzione non funzionante, visto che altri avevano risolto solo con "about:config".
Non trovando altro ho voluto provare anche quello ed... era la soluzione.  :oops:
Magari potrà servire a qualcun'altro... :wink:
« Ultima modifica: 01 Ottobre 2016 10:58:29 da Plink »

Offline flod

  • Amministratore
  • Post: 15033
    • http://www.flod.org
Re: Rimuovere elenco Pocket
« Risposta #5 il: 01 Ottobre 2016 11:04:55 »
Scusate, ma avete provato semplicemente a Personalizzare il menu e togliere l'icona. Dovrebbe sparire anche la voce in Segnalibri.

Offline michro

  • Moderatore
  • Post: 19223
Re: Rimuovere elenco Pocket
« Risposta #6 il: 01 Ottobre 2016 11:10:14 »
Confermo ;-)
Non è necessario passare dall'about:config, basta trascinarlo dalla barra degli strumenti nell'area "Strumenti e caratteristiche aggiuntive" e al termine della personalizzazione scompare dai segnalibri
https://support.mozilla.org/it/kb/Come%20personalizzare%20la%20Barra%20degli%20strumenti

Offline Iceberg

  • Moderatore
  • Post: 7774
Re: Rimuovere elenco Pocket
« Risposta #7 il: 01 Ottobre 2016 11:28:58 »
Tasto destro sull'icona di Pocket e opzione Rimuovi dalla barra degli strumenti che lo rimuove anche dai segnalibri.
Però il parametro extensions.pocket.enabled resta true.
Mi sembra di capire che Pocket senza Firefox account non si possa usare. E' vero?

Offline michro

  • Moderatore
  • Post: 19223

Offline Plink

  • Post: 33
Re: Rimuovere elenco Pocket
« Risposta #9 il: 03 Ottobre 2016 09:20:30 »
Confermo ;-)
Non è necessario passare dall'about:config, basta trascinarlo dalla barra degli strumenti nell'area "Strumenti e caratteristiche aggiuntive" e al termine della personalizzazione scompare dai segnalibri
https://support.mozilla.org/it/kb/Come%20personalizzare%20la%20Barra%20degli%20strumenti

E' la prima cosa che ho fatto subito appena vista quella icona che nemmeno conoscevo... come ogni altra "personalizzazione" di FF appena aggiorno a nuova versione.
E sul momento "sembrava" tutto come prima.
Solo dopo mi sono accorto della cartella "Pocket" nei segnalibri che non riuscivo a togliere neanche da "Visualizza tutti i segnalibri"... ed è per questo che ho iniziato la ricerca con Google per possibili soluzioni.
E visto che quelle che ho trovato non funzionavano ho scritto in questo forum... ma non volevo dilungare troppo.


Viste le obiezioni specifico meglio.

Sul mio sistema principale (WXP SP3) NON è bastato (nell'ordine di esecuzione):
1) Visualizza + Barre degli strumenti + Personalizza > trascinare via l'icona.
Questo è servito SOLO per la Barra degli strumenti...
2) In about:config modificare browser.pocket.enabled in false.
In Preferiti c'era ancora.
3) In about:config aggiungere extensions.pocket.enabled settato in false
In Preferiti c'era ancora.

Solo DOPO l'aggiunta di:
*) userchrome.css con il codice di Underpass
FINALMENTE è sparita anche l'icona dai Segnalibri. 

Spero che così tutta la procedura che ho seguito sia più chiara...


Comunque la "stranezza" è che quando l'ho aggiornato su WXP SP3 si è comportato come ho descritto sopra.
Quando l'aggiornamento l'ho fatto anche sul 2° PC (W7Pro SP1 che uso solo per i giochi online; mi servivano le DX11), non mi ha dato nessun problema particolare... anzi quell'icona non l'ho nemmeno trovata tra i Segnalibri ? ! ?  :o

Evidentemente ci sono delle differenze tra vari S.O. che determinano anche comportamenti diversi di FF.




P.S.
Se servono altre info più specifiche, basta chiedere...  :wink:
« Ultima modifica: 03 Ottobre 2016 09:39:22 da Plink »

0 Utenti e 1 Visitatore stanno visualizzando questo topic.