Notizie: scarica ora l'ultima versione disponibile di Thunderbird!

Autore Topic: Il nuovo SeaMonkey 2.53.8.1 e le icone di posta e browser nella barra di avvio  (Letto 272 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline markinson

  • Post: 91
Salve a tutti!  :)

In due giorni ho già infastidito il forum con le mie strampalate richieste ... ed ecco la seconda, sempre relativa a SeaMonkey.

Stamattina, in automatico (finalmente sono tornati gli aggiornamenti automatici!!! immagino sia dipeso da QUESTO), il mio vecchio SeaMonkey 2.53.8 mi ha proposto di applicare l'ultimo aggiornamento, per passare alla corrente versione 2.53.8.1.
Così ho fatto.

Tuttavia ho notato un cambiamento - e io odio profondamente i cambiamenti, ossia: mentre in precedenza, prima di lanciare qualsiasi componente della suite, potevo avere due distinte icone, una per aprire immediatamente la posta ("C:\Program Files (x86)\SeaMonkey\seamonkey.exe" -mail) e l'altra per aprire direttamente il browser ("C:\Program Files (x86)\SeaMonkey\seamonkey.exe"), già pronte e disponibili nella barra di avvio, adesso - "a riposo" - posso tenere solo un'icona per l'intera suite.

Cerco di spiegarmi con qualche screenshot.

Con SeaMonkey ancora chiuso, sulla barra di avvio avevo due icone a disposizione:


Dopo l'ultimo aggiornamento di SM alla versione 2.53.8.1, nonostante i miei tentativi (vedere infra), riesco ad avere solo un'icona nella barra di avvio:


Ho prima rimosso l'unica icona della suite presente nella barra delle applicazioni (barra di avvio) con "Rimuovi dalla barra delle applicazioni", poi ho provato a trascinare i due distinti collegamenti, alla posta e al browser, presenti sul desktop, ma ne viene accettato soltanto uno. Il secondo resta non collocabile nella barra di avvio con un bel divieto di accesso.

Sono anche andato sotto la cartella "C:\Users\utente\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar" e copiato manualmente i due collegamenti ("C:\Program Files (x86)\SeaMonkey\seamonkey.exe" -mail e "C:\Program Files (x86)\SeaMonkey\seamonkey.exe") presenti sul desktop, ma nulla: il metodo non funziona! Così facendo non viene caricata nessuna delle due icone.
Ovviamente, in mezzo, ho messo un riavvio dell'elaboratore, per sperare che i cambiamenti venissero "caricati".

Questa situazione l'ho rilevata in entrambe le macchine, due, dove ho SeaMonkey.

Qualche consiglio? Grazie!

« Ultima modifica: 31 Luglio 2021 17:40:51 da markinson »

Offline miki64

  • Moderatore
  • Post: 32547
Sono anche andato sotto la cartella "C:\Users\utente\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar" e copiato manualmente i due collegamenti ("C:\Program Files (x86)\SeaMonkey\seamonkey.exe" -mail e "C:\Program Files (x86)\SeaMonkey\seamonkey.exe") presenti sul desktop, ma nulla: il metodo non funziona! Così facendo non viene caricata nessuna delle due icone.
Questo metodo lo avrei adottato io al posto tuo, non capisco perché non funzioni... la vedo dura!  :sbat:

Ciao, miki.

Offline iacchi

  • Amministratore
  • Post: 6342
    • iacchiblog
Sinceramente non so che dirti, ma mi sembra un problema di Windows piu' che di SeaMonkey (?). Vale la pena provare a chiedere sul forum inglese. Come te la cavi con la lingua d'Albione?

Offline markinson

  • Post: 91
Sinceramente non so che dirti, ma mi sembra un problema di Windows piu' che di SeaMonkey (?).
Lo avevo pensato anch'io: questo è un altro colpo basso di Windows. Però mi è capitato in due differenti elaboratori (uno in ufficio e l'altro a casa), aggiornati praticamente in contemporanea e appena aggiornati ho visto diventare "generica" l'iconcina che utilizzavo per aprire la posta.
E' come se - il sistema operativo, sembrerebbe, in effetti - non accettasse più quel doppio collegamento. Perché in realtà si parla di due collegamenti distinti. Meglio: è lo stesso collegamento e uno dei due ha un parametro in più "-mail", per aprire la posta.

Poi com'è che fino a prima dell'aggiornamento ha funzionato la soluzione con due icone e adesso all'improvviso non è più accettata?  :sbat:

Vale la pena provare a chiedere sul forum inglese. Come te la cavi con la lingua d'Albione?

ehm ...  :oops: :oops: :oops: ... potrei provare a confezionare una richiesta, magari servendomi di qualche traduttore online.
In realtà qui ci vorrebbe, forse, direttamente ewong ...

Offline iacchi

  • Amministratore
  • Post: 6342
    • iacchiblog
ok, allora poi provo io a scrivere su mozillazine, ma te ricordamelo in serata perche' al 99.9% me ne scordo :P

Offline markinson

  • Post: 91
Guarda, non voglio approfittare della tua cortesia.

Se sei d'accordo, facciamo così: adesso provo a buttare giù, servendomi del traduttore di Google, la richiesta di aiuto.
Poi la pubblico su mozillazine e magari anche come commento alla nuova release direttamente sul blog di SeaMonkey.

Tu, questo ti chiedo, se puoi, verifica e correggi il tiro qualora non mi fossi ben spiegato o ritenessi necessario rettificare/integrare.

Ok?

Offline markinson

  • Post: 91
Fatto!

Ho sia lasciato un commento sul blog di SeaMonkey, in calce all'articolo relativo alla nuova versione 2.53.8.1, sia aperto un argomento in mozillaZine (QUI).

Vedremo ...
Grazie ancora a tutti!

Offline crazy.cat

  • Post: 455
Poi com'è che fino a prima dell'aggiornamento ha funzionato la soluzione con due icone e adesso all'improvviso non è più accettata?  :sbat:
Ciao Ma...rkinson  :lol:, in effetti confermo lo strano problema.
Non serve neanche creare un collegamento a un batch che ti avvia seamonkey, per windows sono sempre lo stesso collegamento e ne aggiungi uno solo alla barra.
Uno dei tanti bug strani di windows.

Offline markinson

  • Post: 91
Ciao Ma...rkinson  :lol:
:D :D :D ... sei un felino sempre in agguato, eh!  :lol:

in effetti confermo lo strano problema.
Anche tu usi SeaMonkey? Non ci credo!!!  :P

Uno dei tanti bug strani di windows.
Magari dipende da Windows, per carità, ma com'è che è spuntato fuori dopo l'update di SeaMonkey ... fino a stamattina, da decenni, le due iconcine, in entrambi le macchine, erano lì belle e carine e poi puff!

Comunque, con qualche click in più, ho trovato un banale escamotage: basta fare tasto destro sull'icona e scegliere quale modulo della suite di SeaMonkey aprire per primo ... beh, almeno s'è guadagnato lo spazio di un'icona sulla taskbar.  :shock:

Offline crazy.cat

  • Post: 455
Anche tu usi SeaMonkey? Non ci credo!!!  :P
Non lo uso, lo avevo installato apposta per te.
Comunque magari ci scappa una recensione dopo brave e vivaldi.

Windows non accetta neanche l'aggiunta di un nuovo link di firefox a cui aggiungi per esempio l'opzione -p.
Curiosa la cosa, cercherò info appena posso.

Offline iacchi

  • Amministratore
  • Post: 6342
    • iacchiblog
Ho sia lasciato un commento sul blog di SeaMonkey, in calce all'articolo relativo alla nuova versione 2.53.8.1, sia aperto un argomento in mozillaZine (QUI).

mi pare sia sufficientemente comprensibile :)

Offline markinson

  • Post: 91
Grazie, ancora una volta, a tutti, per ciascun contributo e per il supporto!

Non lo uso, lo avevo installato apposta per te.
Grazie, in modo speciale! Sempre tuo debitore!!!  :)

Comunque magari ci scappa una recensione dopo brave e vivaldi.
Sarebbe, almeno per me, molto molto interessante! A dire il vero, secondo il mio metro, SM potrebbe non brillare in termini di prestazioni e soprattutto di memoria che occupa una volta lanciato, ma, oltre al fascino della storia che si porta appresso, avere tutto (gestore di posta, browser, composer HTML, etc.) in un'unica soluzione lo rende davvero speciale.

Windows non accetta neanche l'aggiunta di un nuovo link di firefox a cui aggiungi per esempio l'opzione -p.
Curiosa la cosa, cercherò info appena posso.
Molto curiosa questa cosa. Già. E' come se, dopo l'aggiornamento di SeaMonkey, Windows si fosse accorto dell'esistenza di quei due collegamenti, fatti in quel modo, e non li accettasse più.

mi pare sia sufficientemente comprensibile :)
Ok! Grazie per aver verificato!

A presto a tutti!

Offline markinson

  • Post: 91
Eureka! ... e non è completamente farina del mio sacco!

Riporto, un po' in estratto, quanto emerso nella discussione aperta in mozillaZine: QUI.

Attingendo a un suggerimento fornito nella conversazione sopra segnalata, così mi sono mosso:
  • prima di tutto ho rimosso dalla barra di avvio (barra delle applicazioni) SeaMonkey (facendo click destro con il mouse e poi "Rimuovi dalla barra delle applicazioni");
  • quindi ho aperto il menù Start e ho cercato la cartella SeaMonkey; una volta trovata, singolarmente, sia per "SeaMonkey Mail" sia per "SeaMonkey" (browser), ho fatto click destro e selezionato la voce "Aggiungi a Start";
  • ho aperto di nuovo Start e trovato, nella finestra/frame di Start, le due icone, della posta e del browser, che, singolarmente ho trascinato sulla barra delle applicazioni (barra di avvio).

L'inconveniente, purtroppo, (perché c'è un inghippo) è che cliccando sull'icona della posta piuttosto che su quella del browser, una volta aperto il programma, compare nella barra delle applicazioni una terza icona. Per cui si avranno le due icone per avviare la posta e il browser (quelle da me trascinate), più una nuova icona ("evidenziata") di SeaMonkey per il modulo appena aperto!

Alla fine, forse terrò solo l'icona generica di SeaMonkey e, ogni volta cliccando su di essa con il pulsante destro, sceglierò di aprire il componente che mi interessa. In questo modo il numero delle icone di SeaMonkey aperto è quello "corretto": cioè tante icone sulla barra delle applicazioni per quante componenti della suite effettivamente lanciate.

Offline markinson

  • Post: 91
A proposito dell'icona di SeaMonkey nella barra delle applicazioni (taskbar), se cliccando con il tasto destro del mouse non dovesse comparire l'elenco con le "Attività" tipiche messa a disposizione dalla suite (come apertura della posta, apertura della rubrica, apertura di una nuova finestra del browser, etc.), qualcuno  :fischio:  ha provato (e per ora tiene) un trucchetto, intervenendo sulla preferenza/proprietà "browser.taskbar.lists.frequent.enabled", dentro "about:config", da impostare a "false".

Per maggiori dettagli e qualche screenshot: QUI.

Non vorrei essere incorso in un cross-posting ... ci tenevo soltanto a segnalare, in questo forum specializzato per i programmi della grande famiglia Mozilla, un trucco che può rivelarsi - spero - utile nel caso di comportamento strano di SeaMonkey.

Insomma, ultima delle mie intenzioni è quella di infrangere le regole del forum ... se fosse capitato, rettificate/correggete/eliminate questo post.

Offline iacchi

  • Amministratore
  • Post: 6342
    • iacchiblog
va bene cosi', non ti preoccupare :)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.