Notizie: è uscita la versione 68 di Thunderbird! Scopri tutte le novità!

Autore Topic: Firefox 75 problema con dispositivi di sicurezza (smartcard)  (Letto 1040 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline alcr

  • Post: 8
Ciao. È la prima volta che scrivo nel forum.

Premetto che fino alla versione precedente di Firefox era possibile caricare una dll (windows 10) per poter utilizzare una smart card.

Opzioni -> Dispositivi di sicurezza -> Carica
La libreria nello specifico è asepkcs.dll, che come ho già scritto veniva caricata correttamente fino alla versione di Firefox precedente.
Con Firefox 75 ricevo questo errore che dice ben poco: I"mpossibile aggiungere il modulo".

Qualcuno ha riscontrato lo stesso problema caricando un dispositivo di sicurezza? È dovuto a questa specifica libreria o a qualche bug di Firefox 75?

Grazie

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23650
    • Mozilla Italia
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #1 il: 09 Aprile 2020 10:43:15 »
Ciao, sinceramente non conosco il problema. Da quanto tempo hai installato questo driver? Hai provato a vedere se esiste una versione più aggiornata?

Offline alcr

  • Post: 8
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #2 il: 09 Aprile 2020 11:01:43 »
Ciao, grazie per la risposta.
Sia sul sito della regione Toscana che sul sito del MEF, non c'è un pacchetto di installazione più nuovo.
Quel che vorrei capire è se appunto è la versione di questa libreria che non è più buona con Firefox 75 o se è Firefox 75 stesso ad avere problemi nel caricare qualsiasi libreria.
« Ultima modifica: 09 Aprile 2020 11:27:19 da alcr »

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23650
    • Mozilla Italia
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #3 il: 09 Aprile 2020 11:32:17 »
Senza sapere né leggere e né scrivere, ti suggerirei di scaricare una versione ESR e utilizzare quella solo per il lettore di smart card.

Offline alcr

  • Post: 8
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #4 il: 09 Aprile 2020 12:13:46 »
ESR può essere un ripiego per il momento, giusto.

Comunque ho provato con la dll delle carte OBERTHUR e IDEMIA (bit4opki.dll) e la carica.
Invece con le dll per le carte ACTALIS (asepkcs.dll) e ATOS (cardos11.dll) dice che non può aggiungere il modulo.

Offline alcr

  • Post: 8
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #5 il: 10 Aprile 2020 12:29:59 »
Accidenti! Pare che con l'ultimo aggiornamento di Firefox abbiano proprio bloccato il caricamento della dll

The fix is to block asepkcs.dll (version<=6.5.0.5) from being loaded.
https://bugzilla.mozilla.org/show_bug.cgi?id=1560052

Il problema è appunto che sui siti istituzionali (es. https://sistemats1.sanita.finanze.it/portale/elenco-driver-cittadini-modalita-accesso), non c'è un pacchetto più aggiornato che installi presumibilmente una versione più nuova della dll.

Offline alcr

  • Post: 8
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #6 il: 10 Aprile 2020 13:13:00 »
Ah! Non è un caso isolato. Ecco un'altra segnalazione dello stesso problema:

https://www.reddit.com/r/firefox/comments/fyckfr/firefox_750_cannot_install_security_device_unable/

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23650
    • Mozilla Italia
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #7 il: 10 Aprile 2020 13:40:56 »
Considera comunque che questo pacchetto è del 2016. Se non ricordo male è stato anche responsabile di tantissimi errori in Firefox e Thunderbird in occasione dell'aggiornamento a Windows 10 alle versioni 1803 e 1809.

Offline alcr

  • Post: 8
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #8 il: 14 Aprile 2020 17:33:33 »
E lo considero sì.
Ma se Regioni e Agenzie che forniscono software, smartcard e lettori non aggiornano i software, che si fa?
Per fortuna questa è roba di crittografia e sicurezza.... un software che deve garantire sicurezza e riservatezza non aggiornato dal 2016..... quanto sicuro sarà?

Comunque sai cosa rispondono dall'help desk della Regione Toscana per esempio? Indovina?
"Siamo a conoscenza del problema, consigliamo di usare una versione di Firefox più vecchia o di usare un altro browser, per esempio Chrome"...

Offline acilio

  • Post: 2
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #9 il: 16 Aprile 2020 23:50:46 »
uso la smartcard regolarmente da anni e da quando ho aggiornato alla versione 75.0 mi succede la stessa cosa e non posso aggiungere il modulo, anche io vivo in regione toscana e mi hanno detto di installare la versione Firefox precedente almeno fino a quando non si risolve il problema.
Ci sono aggiornamenti in proposito?

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23650
    • Mozilla Italia
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #10 il: 17 Aprile 2020 08:47:40 »
Ciao, non è per partito preso che spezzo una lancia in favore di Mozilla: i sistemi vanno aggiornati. Non si può immaginare di usare lo stesso driver del 2016 su un PC del 2020.

Quel driver è stato messo in blacklist da Mozilla per motivi secondo me noti, nel senso che è quello che aveva provocato blocchi in Firefox e Thunderbird su Windows 10.

A questo punto, il consiglio che vi posso dare - nuovamente - è di installare la versione ESR e tenervi quella versione per utilizzare il lettore di smartcard nell'attesa che - bontà sua - la regione decida di rilasciare una procedura aggiornata.

Eventualmente, nulla vieta di usare un altro browser in emergenza. 

Offline deckard

  • Post: 2935
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #11 il: 17 Aprile 2020 12:36:18 »
È di enorme importanza che dispositivi di sicurezza e lettori di smart card abbiano sempre dei driver aggiornati e forniti dall'ente di competenza (sulla base del lavoro svolto dal produttore e compatibile con le nuove versioni dei programmi e dei sistemi operativi).
Capisco che il ciclo di rilasci rapidi possa aver creato varie difficoltà, ma non giustifico l'inerzia in un settore ove sicurezza e aggiornamenti rivestono una enorme importanza e in considerazione del fatto che i programmi per gestire il lettore di smart card in questione sono stati rilasciati tra il 2015 e il 2016 e sicuramente il produttore della componentistica ha rilasciato aggiornamenti sia hardware che software.
Mozilla ha anche il compito di garantire il corretto funzionamento dei programmi che sviluppa e mantiene e una minore presenza di arresti anomali e di blocchi pur proseguendo con lo sviluppo. (Dato che il mondo di Internet è in continua evoluzione e non ci si può fermare...)
Dato che anche l'attuale rilascio ESR ha un ciclo vitale la soluzione proposta posticipa o sposta il problema, ma non lo risolve.
Concordo con Underpass sull'esigenza di adoperare sistemi e programmi aggiornati.
Se poi non si è d'accordo con lo sviluppo di uno specifico programma va bene l'utilizzo di altri browser, ma sconsiglio l'utilizzo di versioni non più mantenute.
Se Regioni e Agenzie che forniscono software, smartcard e lettori non aggiornano i software, posso dire che sarebbe compito dell'utenza contattarli e chiedere ragguagli?

Offline alcr

  • Post: 8
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #12 il: 18 Aprile 2020 08:48:40 »
Buoni buoni. :D Deckard e Underpass. Cos'è questa alzata di scudi?
Nessuno qui ha scritto che Firefox o Mozilla sono la causa del problema o hanno fatto un brutto lavoro. È giusto che lo sviluppo vada avanti e vengano rilasciati aggiornamenti frequenti.

Anzi, personalmente mi son chiesto come mai questi software per la smartcard siano così vecchi; e ho pure interpellato l'helpdesk della Regione.
Il sito del produttore della smartcard non fornisce software e non ha form di contatto o email. Evidentemente si interfaccia solo coi clienti (Regioni e Agenzie varie).
Dev'esserci di mezzo anche Aruba, guarda caso.
E saprete bene come funzionano gli helpdesk. Ti risponde un povero cristo, che ne sa meno di te, usa risposte preconfezionate, e i problemi probabilmente non arriveranno mai ai piani alti.

L'unica cosa che dispiace è che in molti ambiti, soprattutto istituzionali, l'uso di Firefox verrà per forza di cose abbandonato.
La vedo dura che esca un aggiornamento di questa libreria in tempi rapidi (sono anni che sul sito delle Regioni c'è la solita versione del software per la smart card).

Quindi scrivere qui può servire per sollevare il problema, che esiste (non "per colpa" di Mozilla), e chi ci si imbatte può unire la sua voce al coro. E magari qualcuno con dei contatti in giro per il mondo e con maggiore influenza di un semplice utente (che so, uno sviluppatore, un community manager) possa mettersi lui in contatto con chi fornisce queste librerie.

Offline alcr

  • Post: 8
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #13 il: 18 Aprile 2020 08:57:15 »
Comunque, come ho commentato in questo altro bug https://bugzilla.mozilla.org/show_bug.cgi?id=1629002 ho trovato una versione più nuova della libreria su un sito del collegio degli avvocati argentino :)
Ma andando a caricare la DLL dalle preferenze, dà il solito problema. Provando invece a caricarla usando il file policies.json, mentre con la versione più vecchia non la caricava comunque, in questo caso me la ritrovo fra i dispositivi di sicurezza (poi non ho avuto modo di provare se effettivamente funziona).

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23650
    • Mozilla Italia
Re:Firefox 75 problema con dispositivi di sicurezza (smartcard)
« Risposta #14 il: 09 Maggio 2020 11:25:44 »
Ciao, riporto a galla questo thread perché ho visto che è stato appena pubblicato un articolo relativo a problemi di smartcard in Estonia:

https://support.mozilla.org/en-US/kb/workaround-make-estonian-smartcards-work-firefox-7

Magari anche il vostro problema si risolve nello stesso modo: ci farebbe anzi piacere se voi poteste eseguire questo test per riportarlo nel bug.

https://bugzilla.mozilla.org/show_bug.cgi?id=1636100

Grazie

0 Utenti e 1 Visitatore stanno visualizzando questo topic.