Notizie: scarica ora l'ultima versione disponibile di Firefox!

Autore Topic: BUG? Firefox non ricarica la pagina dopo che clicco su "ritrasmetti" nel popup  (Letto 544 volte)

0 Utenti e 2 Visitatori stanno visualizzando questo topic.

Offline utente12345

  • Post: 14
Buongiorno a tutti,

in una pagina web che arriva da un form HTML, Firefox non esegue alcuna azione dopo che premo F5 e clicco su "ritrasmetti" per ritrasmettere i dati del form.

- premo F5
- compare il messaggio "Per visualizzare questa pagina Firefox deve ritrasmettere le informazioni già inviate. Questa operazione ripeterà qualsiasi azione eseguita in precedenza, ad esempio una ricerca o una conferma d’ordine. ANNULLA - RITRASMETTI"
- premo RITRASMETTI
- non succede assolutamente niente, come se avessi premuto ANNULLA  :sbat:...

L'anomalia mi è successa solo su una determinata pagina.

Tale funzionalità di Firefox non dovrebbe essere esente completamente dal codice HTML della pagina?

Come è possibile che non funziona?

Come faccio a fare in modo che funzioni sempre?

Ho assolutamente bisogno che funziona, non voglio cambiare browser  :fx: perché per lavoro ho bisogno spessissimo di eseguire questa operazione.

Grazie
« Ultima modifica: 01 Luglio 2019 11:55:38 da utente12345 »

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23120
    • Mozilla Italia
Se premi CTRL+F5 che succede?

Offline utente12345

  • Post: 14
Compariva la stessa schermata di richiesta per rinviare i dati ma poi non faceva niente...

Ora purtroppo non ho più modo di ritestare sulla stessa pagina di prima...

Ma cosa poteva essere il problema?

Grazie.

Offline utente12345

  • Post: 14
Mi è appena ricapitato.

Tengo la pagina aperta per fare eventuali test da voi richiesti.

Con CTRL+F5, CTRL+R, SHIFT+CTRL+R appare il messaggio ma cliccando su ritrasmetti non succede niente.
Anche tramite il pulsante di "aggiorna pagina" dell'interfaccia di firefox fa la stessa cosa.

Nella console non è presente alcun errore.

Grazie.
« Ultima modifica: 11 Giugno 2019 11:35:14 da utente12345 »

Offline utente12345

  • Post: 14
Qualcuno può gentilmente aiutarmi per favore?

Offline utente12345

  • Post: 14

Qualcuno può gentilmente aiutarmi per favore?

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23120
    • Mozilla Italia
Scusami, ti vorrei aiutare, ma confermi  - come tu stesso hai detto - che il problema lo verifichi solo su una pagina? Qual è questa pagina? C'è modo di replicare il problema per noi?

Hai provato a eliminare i cookie e la cache?
Hai estensioni installate? Hai provato a disattivarle?

Offline utente12345

  • Post: 14
Anche senza alcuna estensione attiva il problema rimane e si ripete anche su altre pagine.

In entrambe le pagine l'HTML non c'è nessuno script (jQuery e/o JavaScript) che blocca le funzionalità del browser.

È semplice codice HTML con dei form, javascript e jQuery per dei checkbox e calcolo di alcuni totali.

Nel form vengono passati anche dei dati via input hidden, contenenti valori con apici singoli e  doppi
Codice: [Seleziona]
' ".

Non credo sia possibile fornirvi delle pagine di test per riprodurre l'errore in quanto non so dove si trova e il perché avviene: ci potrei mettere settimane...

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23120
    • Mozilla Italia
E quindi è impossibile affermare che il problema sia causato da Firefox, così come è impossibile affermare che il problema NON sia causato da Firefox.

Se non è riproducibile in ogni analoga circostanza, e che anzi può ripresentarsi dopo diverse settimane, direi che è un problema non bloccante.

Offline utente12345

  • Post: 14
Se non è riproducibile in ogni analoga circostanza, e che anzi può ripresentarsi dopo diverse settimane, direi che è un problema non bloccante.

Al contrario, è bloccante da quando ho iniziato ad usare questa versione del browser...
Ho aspettato del tempo a rispondere a questa discussione perché non ne avevo il tempo prima ma preciso che l'anomalia si è sempre ripresentata dal primo giorno che l'ho segnalato qui. La cosa strana è che si presenta solo sulle stesse pagine, anche se con dati diversi.

La mia impressione è che ci sia dell'HTML (non script) che non viene rilevato correttamente, oppure ci sono dei tag non chiusi che nelle versioni precedenti di FF venivano rilevati e chiusi da FF stesso. O qualcosa di simile.

E quindi è impossibile affermare che il problema sia causato da Firefox, così come è impossibile affermare che il problema NON sia causato da Firefox.
Se la stessa identica pagina funziona sulle versioni precedenti di FF, escluderei che NON sia causato da Firefox.

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 23120
    • Mozilla Italia
Citazione
Al contrario, è bloccante da quando ho iniziato ad usare questa versione del browser...

E ti chiedo, ancora una volta: ci dai il modo di riprodurre il problema? Altrimenti parliamo di nuddru ammiscatu cu nenti...

Offline utente12345

  • Post: 14
Appena riesco provo a produrre dell'HTML che riproduce l'anomalia...

Esiste una console degli errori di FF in tempo reale che posso leggere durante l'azione di aggiorna pagina che non si esegue?

Offline Winfox

  • Post: 2758
Hai detto che il problema con la versione precedente non si presentava, quindi potresti fare un downgrade, provare con un profilo pulito, provare per scrupolo con un altro browser.

0 Utenti e 2 Visitatori stanno visualizzando questo topic.