Autore Topic: Debian Testing - Firefox non riconosce H264  (Letto 4090 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline anonymous85

  • Post: 20
Re: Debian Testing - Firefox non riconosce H264
« Risposta #15 il: 18 Giugno 2015 14:57:01 »
Che pacchetti hai di gstreamer?

gir1.2-gst-plugins-base-1.0

gir1.2-gstreamer-1.0

gstreamer0.10-alsa

gstreamer0.10-plugins-base

gstreamer1.0-libav

gstreamer1.0-plugins-base

gstreamer1.0-plugins-good

gstreamer1.0-plugins-ugly

gstreamer1.0-x

libgstreamer-plugins-base0.10-0

libgstreamer-plugins-base1.0-0

libgstreamer0.10-0

libgstreamer1.0-0

Offline klades

  • Moderatore
  • Post: 5783
    • http://www.nic-nac-project.org/~kaosmos
Re: Debian Testing - Firefox non riconosce H264
« Risposta #16 il: 18 Giugno 2015 15:41:58 »
Se vai a about:buildconfig , vedi tra i flag di compilazione --enable-gstreamer=1.0 ?

Se non c'è, credo che il tuo Firefox stia usando gstreamer-0.10 e quindi dovresti installare i plugin gstreamer0.10-plugins-good gstreamer0.10-ffmpeg.

Offline anonymous85

  • Post: 20
Re: Debian Testing - Firefox non riconosce H264
« Risposta #17 il: 18 Giugno 2015 15:53:45 »
Se vai a about:buildconfig , vedi tra i flag di compilazione --enable-gstreamer=1.0 ?

Se non c'è, credo che il tuo Firefox stia usando gstreamer-0.10 e quindi dovresti installare i plugin gstreamer0.10-plugins-good gstreamer0.10-ffmpeg.

No...non c'è  :(

cmq credo che hai colpito nel segno

su google ho trovato questo

https://bugzilla.mozilla.org/show_bug.cgi?id=1159086

Offline klades

  • Moderatore
  • Post: 5783
    • http://www.nic-nac-project.org/~kaosmos
Re: Debian Testing - Firefox non riconosce H264
« Risposta #18 il: 19 Giugno 2015 10:15:31 »
Mi sa che ffmpeg è deprecato nelle ultime release di Debian e quindi non lo trovi nel repository ufficiale.

Prova a installare ffmpeg e gstreamer0.10-ffmpeg da un'altra fonte, tipo http://deb-multimedia.org/

Io uso una version vecchia di Debian e paradossalmente vedo i video H264 perché ho ancora questi due pacchetti.

Offline Winfox

  • Post: 4346
Re: Debian Testing - Firefox non riconosce H264
« Risposta #19 il: 19 Giugno 2015 11:54:32 »
Mi sa che ffmpeg è deprecato nelle ultime release di Debian e quindi non lo trovi nel repository ufficiale.

Urca. Quello è un pacchetto FONDAMENTALE su tutte le distribuzioni, tutte le guide per maneggiare materiale multimediale si riferisce ad esso.
Dunque siamo in un periodo di passaggio ad altro?

Offline Iceberg

  • Moderatore
  • Post: 8643
Re: Debian Testing - Firefox non riconosce H264
« Risposta #20 il: 19 Giugno 2015 12:25:39 »
@anonymous85: ti sconsiglio vivamente di installare pacchetti da quel repository in quanto hanno poi dato problemi di dipendenze.

Ho quel repository da sempre e non mi ha mai dato problemi.
E' da lì che proviene il fondamentale ffmpeg.

Sarebbe così:
Codice: [Seleziona]
Si consiglia agli utenti di usare avconv dal pacchetto libav-tools invece di ffmpeg.Tuttavia ffmpeg va molto meglio. Provato e rimosso libav-tools, va male, quando va.

Offline klades

  • Moderatore
  • Post: 5783
    • http://www.nic-nac-project.org/~kaosmos
Re: Debian Testing - Firefox non riconosce H264
« Risposta #21 il: 19 Giugno 2015 12:39:39 »
@anonymous85: ti sconsiglio vivamente di installare pacchetti da quel repository in quanto hanno poi dato problemi di dipendenze.

Ho quel repository da sempre e non mi ha mai dato problemi.
E' da lì che proviene il fondamentale ffmpeg.

Io anche non ho mai avuto problemi, ho sempre avuto attenzione ad usarlo selettivamente solo per i pacchetti multimediali (ffmpeg e dintorni).

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 24613
    • Mozilla Italia
Re: Debian Testing - Firefox non riconosce H264
« Risposta #22 il: 19 Giugno 2015 12:42:18 »
Io tempo fa ho dovuto fare un'operazione chirurgica per risolvere problemi di dipendenze. Forse a voi non è capitato perché usate la Stable ma io uso la Testing (e anche il nostro amico @anonymous85)

Offline Mte90

  • Post: 1325
    • Mte90.Net
Re: Debian Testing - Firefox non riconosce H264
« Risposta #23 il: 19 Giugno 2015 12:58:00 »
Io uso debian sid con firefox sia la versione iceweasel compilata da debian sia aurora scaricata dai server mozilla e con quei parametri attivati in about:config non ho problemi.
Inoltre debian-multimedia l'ho tolto da tempo perchè mi creo parecchi problemi quindi mi scarico i codec direttamente da debian.

Offline anonymous85

  • Post: 20
Re: Debian Testing - Firefox non riconosce H264
« Risposta #24 il: 19 Giugno 2015 13:20:28 »
Io tempo fa ho dovuto fare un'operazione chirurgica per risolvere problemi di dipendenze. Forse a voi non è capitato perché usate la Stable ma io uso la Testing (e anche il nostro amico @anonymous85)

La testing in poche parole ha solo il nome tale...poichè è molto stabile (a conti fatti una Ubuntu LTS) per le dipendenze io non ho mai avuto problemi

Codice: [Seleziona]
apt-get -f install
e passa la paura  :wink:

Riguardo H264 di default...Firefox non lo legge (intendo default)...da quello che ho capito su debian i manutentori di iceweasel hanno appliccato delle patch sul binario Firefox...

Anche perchè su Iceweasel funziona tutto alla perfezione....Firefox no (con i pacchetti che ho citato prima)

Forse gli sviluppatori di Mozilla hanno voluto aspettare che uscisse la versione 8 stabile di debian? la 7 usava (0.10) Debian 8 (1.0) gstreamer

Per me Mozilla deve tener conto di questo...perchè l'utente medio non si mette ad indagare...torna a chrome...  :(
« Ultima modifica: 19 Giugno 2015 13:34:25 da anonymous85 »

Offline klades

  • Moderatore
  • Post: 5783
    • http://www.nic-nac-project.org/~kaosmos
Re: Debian Testing - Firefox non riconosce H264
« Risposta #25 il: 19 Giugno 2015 13:32:56 »
anonymous85, prova a controllare su iceweasel cosa risulta da about:buildconfig, se trovi --enable-gstreamer=1.0

Offline anonymous85

  • Post: 20
Re: Debian Testing - Firefox non riconosce H264
« Risposta #26 il: 19 Giugno 2015 13:50:27 »
anonymous85, prova a controllare su iceweasel cosa risulta da about:buildconfig, se trovi --enable-gstreamer=1.0

 :D

http://i58.tinypic.com/2u8vzer.png

si  8)

Offline klades

  • Moderatore
  • Post: 5783
    • http://www.nic-nac-project.org/~kaosmos
Re: Debian Testing - Firefox non riconosce H264
« Risposta #27 il: 19 Giugno 2015 14:14:59 »
Allora secondo me le cose stanno così: iceweasel ha il supporto per gstreamer1.0 e quindi riesce a decodificare h264 grazie a gstreamer1.0-libav e avconv, invece il tuo Firefox usa gstreamer0.10 e quindi avrebbe bisogno di ffmpeg e gstreamer0.10-ffmpeg.

Quindi o trovi un Firefox compilato con il supporto per gstreamer1.0, oppure installi in qualche modo ffmpeg e gstreamer0.10-ffmpeg (sempre che sia possibile).

Offline Underpass

  • I've got fabric to sell
  • Amministratore
  • Post: 24613
    • Mozilla Italia
Re: Debian Testing - Firefox non riconosce H264
« Risposta #28 il: 19 Giugno 2015 14:37:26 »
Codice: [Seleziona]
apt-get -f install
e passa la paura  :wink:

Concludo l'OT dicendo che "passa la paura" fino ad un certo punto quando la parte multimediale non funziona più e apt ti vuole portare via mezza distribuzione.
In quasi 10 anni di Debian quello è stato un momento abbastanza critico. Per cui, dal momento che in pratica il repo multimedia non mi serve, ho deciso di non utilizzarlo più - da quel momento ho solamente i repo ufficiali.

Offline anonymous85

  • Post: 20
Re: Debian Testing - Firefox non riconosce H264
« Risposta #29 il: 19 Giugno 2015 16:35:14 »
Allora secondo me le cose stanno così: iceweasel ha il supporto per gstreamer1.0 e quindi riesce a decodificare h264 grazie a gstreamer1.0-libav e avconv, invece il tuo Firefox usa gstreamer0.10 e quindi avrebbe bisogno di ffmpeg e gstreamer0.10-ffmpeg.

Quindi o trovi un Firefox compilato con il supporto per gstreamer1.0, oppure installi in qualche modo ffmpeg e gstreamer0.10-ffmpeg (sempre che sia possibile).

Mi sorge una domanda...ma il team mozilla non può compilare il binario linux per Firefox aggiungendo la stringa ac_add_options --enable-gstreamer=1.0:? visto che sorgono questi problemi??

ho provato a installare ffmpeg ma non mi legge lo stesso h264

gstreamer0.10 fffmpeg su debian ormai sta per essere tolto   :sbat: (gradualmente si sta effettuando la migrazione a 1.0)

Codice: [Seleziona]
apt-get -f install
e passa la paura  :wink:

Concludo l'OT dicendo che "passa la paura" fino ad un certo punto quando la parte multimediale non funziona più e apt ti vuole portare via mezza distribuzione.
In quasi 10 anni di Debian quello è stato un momento abbastanza critico. Per cui, dal momento che in pratica il repo multimedia non mi serve, ho deciso di non utilizzarlo più - da quel momento ho solamente i repo ufficiali.

Boh io raramente ho avuto problemi di dipendenze... e quando le ho avute ho sempre risolto con il comando sopra

Poi ognuno risolve come vuole anche non usando il repo multimedia  :wink:
« Ultima modifica: 19 Giugno 2015 16:36:57 da anonymous85 »

0 Utenti e 1 Visitatore stanno visualizzando questo topic.