Notizie: scarica ora l'ultima versione disponibile di Firefox!

Autore Topic: Grosso problema invio fatture con gestionale AD-HOC  (Letto 4465 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline [ b a z ]

  • Post: 9
Grosso problema invio fatture con gestionale AD-HOC
« il: 07 Gennaio 2010 17:27:38 »
Oggi sono imbestialito
ho lottato per sostituire Outlook con TB3 sul pc che viene usato a lavoro per inviare le fatture per email.

dopo avere smadonnato per trasferire i messaggi farlo imparare a chi deve usarlo ecc... iniziano ad usarlo e tutto sembra filare liscio.

Arriva il momento delle fatture.

Il ns gestionale "AD-HOC" prepara il pdf e lo manda con TB3.
Dopo il primo invio telefona un Cliente al quale è arrivata la fattura di un altro (con i listini personalizzati potete immaginarvi che bella figura di merd...) cerchiamo la causa ma senza soluzione, per fortuna era 1 solo.

oggi abbiamo dovuto ristampare una copia di una vecchia fattura, memori dell'errore passato controlliamo, NON è la fattura corretta!!!!

a parte la sequela di moccoli comincio a verificare la causa.

quando Ad-Hoc genera la fattura, mette un file "fattura.pdf" nella temp dell'utente, quando TB lo mette come allegato e prepara l'invio lo carica anche nella cartella MOZ_MAPI sempre nella stessa TEMP.
Finito l'invio o annullando senza salvare DOVREBBE rimuovere il file temporaneo dalla cartella ma invece NO!!! rimane lì per un tempo VARIABILE, per il quale non ne capisco il motivo, così che, ristampando una nuova fattura, "AD-HOC" genera il file corretto nella Temp, ma TB pesca il VECCHIO FILE (con lo stesso nome) dalla MOZ_MAPI inviando di fatto la fattura precedentemente stampata ad un ALTRO CLIENTE!!!

io spero sia una mia impostazione errata sul PC, perchè così sarebbe veramente un GRANDISSIMO RISCHIO usare TB3 a LAVORO!!!

sapete qualcosa dic ome funziona questa TEMP!?
perchè alle volte dalla cartella MOZ_MAPI cancella il file non inviato dopo 1/2 secondo ed altre volte dopo 1minuto è ancora lì!?

P.s.
logicamente finchè usavamo Outlook, tutto queso non succedeva (e Dio solo sa quanto ODIO outlook)

Offline [ b a z ]

  • Post: 9
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #1 il: 08 Gennaio 2010 10:10:33 »
piccolo aggiornamento.:

dopo una serie di verifiche, sembra che SOLO il primo file messo nel primo messaggio di posta rimanga a lungo nella Temp MOZ_MAPI (dalle 9.30 ancora non si è cancellato) mentre i successivi no.
Difatti ho provato inviando un altro allegato il quale è rimasto nella temp dal momento in cui l'ho allegato a quando ho annullato senza salvare. (anche per il primo l'ho allegato ed annullato senza salvare)

Offline gialloporpora

  • サンドロ
  • Moderatore
  • Post: 10806
    • Il blog che non c'è
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #2 il: 08 Gennaio 2010 11:34:54 »

Offline michro

  • Moderatore
  • Post: 20999
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #3 il: 08 Gennaio 2010 12:11:38 »
...e sta andando avanti ancora da Thunderbird 1.5.0.7 senza aver trovato soluzione?

Offline klades

  • Moderatore
  • Post: 5783
    • http://www.nic-nac-project.org/~kaosmos
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #4 il: 08 Gennaio 2010 12:21:27 »
Stando al bug 35919 il file non dovrebbe venir cancellato se è in carico anche in un'altra applicazione (ad es. da adobe reader), nel momento in cui viene chiusa la finestra di composizione.
Capisco che è piuttosto insidioso come bug, non so se esistono workaround.

EDIT --> da alcune prove fatte confermo che in genere Thunderbird non cancella i file nella directory temporanea quando questi sono "bloccati" da altre applicazioni. Ovviamente questo non dovrebbe succedere nei sistemi operativi in cui questo "blocco" non esiste (cioè tutti tranne win, che io sappia).
« Ultima modifica: 08 Gennaio 2010 12:35:01 da klades »

Offline klades

  • Moderatore
  • Post: 5783
    • http://www.nic-nac-project.org/~kaosmos
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #5 il: 08 Gennaio 2010 12:27:25 »
[ b a z ], per caso tu tieni aperto il file temporaneo in moz_mapi con adobe reader quando hai fatto invia (per esempio hai aperto l'allegato dalla finestra di composizione)?

Offline [ b a z ]

  • Post: 9
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #6 il: 08 Gennaio 2010 13:54:58 »
[ b a z ], per caso tu tieni aperto il file temporaneo in moz_mapi con adobe reader quando hai fatto invia (per esempio hai aperto l'allegato dalla finestra di composizione)?

NO

sembrerebbe lo stesso bug anche questo:
https://bugzilla.mozilla.org/show_bug.cgi?id=356808

Offline klades

  • Moderatore
  • Post: 5783
    • http://www.nic-nac-project.org/~kaosmos
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #7 il: 08 Gennaio 2010 16:37:27 »
Sì il bug 356808 riguarda questo problema; è segnato come risolto, ma nel ramo Thunderbird 3.1, il che vuol dire purtroppo che il fix non entrerà mai nel ramo 3.0.

Offline AlexS3

  • Post: 1
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #8 il: 08 Febbraio 2010 10:47:40 »
[ b a z ], per caso tu tieni aperto il file temporaneo in moz_mapi con adobe reader quando hai fatto invia (per esempio hai aperto l'allegato dalla finestra di composizione)?

NO

sembrerebbe lo stesso bug anche questo:
https://bugzilla.mozilla.org/show_bug.cgi?id=356808

Io ho esattamente questo problema con thunderbird 3 sia la 3.0 che la 3.0.1, con la 2.0 non mi faceva questa roba... ho appena fatto una figura di m. con un nostro cliente grazie a questa chicca, lasciando perdere la riservatezza...
Ho mandato un pdf che avevo appena creato e thunderbird è andato a pescare un vecchio file nella cartella temp? che ovviamente non riguardava il cliente a cui era indirizzato il nuovo pdf.
Quando dite che il fix non entrerà nel ramo 3.0 intendete che dovrò aspettare la 3.1 "non 3.0.1"?
Comunque per una cosa del genere si cambia.. e anche in fretta, soprattutto se chi dovrebbe non comprende la gravità del problema.
« Ultima modifica: 08 Febbraio 2010 10:49:45 da AlexS3 »

Offline flod

  • Amministratore
  • Post: 15058
    • http://www.flod.org
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #9 il: 08 Febbraio 2010 11:09:37 »
Quando dite che il fix non entrerà nel ramo 3.0 intendete che dovrò aspettare la 3.1 "non 3.0.1"?
No. La patch è stata caricata nel ramo mozilla1.9.1 (http://hg.mozilla.org/releases/comm-1.9.1/rev/a6b19b17aeae), il che significa che sarà disponibile nel prossimo aggiornamento 3.0.2

Offline emarketer

  • Post: 3
    • Web Marketing Academy
Re: Grosso problema invio fatture con gestionale AD-HOC
« Risposta #10 il: 06 Maggio 2014 11:32:41 »
Baz,
se ti può consolare il rapporto Thunderbird - programma gestionale non è rose e fiori nemmeno nel mio caso...ma non è un problema di thunderbird e comunque  :fx: quindi una soluzione si trova!

0 Utenti e 1 Visitatore stanno visualizzando questo topic.