Notizie: Scarica ora l'ultima versione disponibile di Lightning

Autore Topic: Improvvisamente Firefox non si avvia (Windows 7)  (Letto 2864 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline jumborex

  • Post: 7
    • http://www.cantodellasfinge.net/
Improvvisamente Firefox non si avvia (Windows 7)
« il: 12 Agosto 2012 19:39:37 »
Senza aver installato nulla di nuovo, all'improvviso Firefox non si avvia più sul mio sistema Windows 7: aveva già dato segni di instabilità, ma non si era ancora bloccato del tutto.
Al momento del lancio, appare soltanto una finestra esattamente così:



Leggo sulla Guida di Firefox:

L'errore si verifica improvvisamente
Se Firefox non ha dato problemi in precedenza e l'errore comincia a verificarsi improvvisamente, il problema può avere origine in uno o più file corrotti nelle impostazioni utente. È inutile in questo caso disinstallare e installare nuovamente il programma in quanto le impostazioni utente non vengono rimosse con la disinstallazione. Per verificare se questa è la causa del problema, utilizzare il Gestore profili per creare un nuovo profilo.


La soluzione consigliata è di eliminare il profilo, se ho ben capito:

Premere Windows + R
Nella casella Esegui, digitare:
Codice: [Seleziona]
firefox.exe -p
Fare clic su OK.

Purtroppo se sono abbastanza svelto da fare "Elimina profilo..." la finstra si blocca e non fa nulla.
Se la sto a guardare per qulache secondo pensieroso, riappare lo stesso messaggio di errore di prima e sono daccapo.

Qualcuno ha delle idee?
Grazie.


Offline Ronnie91

  • Post: 2658
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #1 il: 13 Agosto 2012 06:51:58 »
Ciao, hai altri problemi con il PC e/o con altri browser?

Software di sicurezza (antivirus/firewall)?

Offline trekfan1

  • Post: 166
    • http://www.startrekitalia.com
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #2 il: 13 Agosto 2012 07:22:56 »
Sposta la cartella del profilo manualmente (così da verificare se il problema è nel profilo, il percorso è: C:\Users\<nomeutente>\AppData\Roaming\Mozilla\Firefox\Profiles

ovviamente al posto di <nomeutente> ci va il nome dell'account di windows che usi.

Offline miki64

  • Moderatore
  • Post: 19749
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #3 il: 13 Agosto 2012 10:06:11 »
La soluzione consigliata è di eliminare il profilo, se ho ben capito
No, non hai ben capito.
Probabilmente ci saranno pure dei file corrotti, ma se elimini il profilo elimini pure segnalibri, password salvate e tutto il resto, quindi per adesso NON eliminare nulla!

Segui il consiglio di Ronnie91 rispondendoci e magari effettua anche la prova - a browser chiuso - suggerita da trekfan1: in quella maniera il tuo Firefox non troverà un profilo di default e ne creerà uno nuovo, bello pulito.

Offline jumborex

  • Post: 7
    • http://www.cantodellasfinge.net/
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #4 il: 13 Agosto 2012 11:18:38 »
Ciao, hai altri problemi con il PC e/o con altri browser?

Software di sicurezza (antivirus/firewall)?
Dunque, utilizzo normalmente Microsoft IE9, Chrome, Safari, Opera senza nessun problema. Firefox mi dà dei problemi da un po': in particolare non accetta flash in nessun modo. Adesso, poi, non funziona più. :fischio:
Sposta la cartella del profilo manualmente (così da verificare se il problema è nel profilo, il percorso è: C:\Users\<nomeutente>\AppData\Roaming\Mozilla\Firefox\Profiles

ovviamente al posto di <nomeutente> ci va il nome dell'account di windows che usi.
Qui purtroppo non succede nulla: ho due profili nella cartella, uno si chiama dt1xpeva.default e uno si chiama q88lhk8w.Franco, che è il mio nome, completamente vuoto quest'ultimo. Ho provato a spostare default e non parte più nulla. Faccio click, trovo firefox tra i processi, ma nulla appare a schermo. Se poi sposto anche franco, mi appare un avviso: Impossibile proseguire, il profilo risulta mancante (o analogo messaggio) e non dà altre possibilità se non chiudere.

Aggiungo che uso AVG come antivirus, rinforzato da PREVX.

Offline jumborex

  • Post: 7
    • http://www.cantodellasfinge.net/
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #5 il: 13 Agosto 2012 11:57:53 »
Volevo aggiungere che ho provato ad eliminare dei file .js all'interno del profilo, per l'esattezza:

prefs.js
prefs-1.js
prefs-2.js

Ho provato a rimuovere uno per volta praticamente ogni file. Ma dopo aver rimosso questi, eseguito Firefox come amministratore, viene ricreato il file prefs.js e mi appare questa schermata:



forse non vuol dire niente. Il messaggio di errore di memoria appare dopo qualche secondo, quindi non è immediato.

Offline Gioxx

  • Fx OS Social Media Lead
  • Amministratore
  • Post: 6384
    • Gioxx's Wall
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #6 il: 13 Agosto 2012 12:50:46 »
Aggiungo che uso AVG come antivirus, rinforzato da PREVX.

Non vorrei dir boiate (correggimi se sbaglio) ma il secondo citato non è un antivirus anch'esso? Doppio antivirus sul sistema? Lo sai che entrambi caricano (e tanto) la macchina di lavoro dato che fai doppia scansione realtime di ciascun file disco / memoria / altro? Potrebbe anche essere questa la causa dei tuoi problemi :?

Offline jumborex

  • Post: 7
    • http://www.cantodellasfinge.net/
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #7 il: 13 Agosto 2012 13:11:01 »
[...]
Non vorrei dir boiate (correggimi se sbaglio) ma il secondo citato non è un antivirus anch'esso? Doppio antivirus sul sistema? Lo sai che entrambi caricano (e tanto) la macchina di lavoro dato che fai doppia scansione realtime di ciascun file disco / memoria / altro? Potrebbe anche essere questa la causa dei tuoi problemi :?
Hai perfettamente ragione, ma il problema è stato che PREVX mi ha eliminato qualsiasi intromissione di pubblicità non richiesta e io non voglio pubblicità non richiesta. Ad ogni modo, da prove che continuo a fare, è possibile che il problema sia AVG! E mi spiego...
Poiché ci volevano tre/quattro secondi prima che apparisse l'errore di memoria descritto prima, ho provato a premere il tasto Inizia nuova sezione e (meraviglia) Firefox ha ripreso vita!
A quel punto ho provato a installare Flash che negli ultimi mesi non ha mai funzionato sul mio Firefox e allora ricevo questo avvertimento da AVG:



Ho mandato comunicazione in merito ad AVG, ma se qualcuno sapesse che sta succedendo, naturalmente non potrei che ringraziare: la cosa strana è che se faccio la stessa operazione con MS, Opera, Chrome, Safari nessuna segnalazione arriva.
Firefox deve essere proprio popolato da strani spettri nel mio sistema. :cerca:

Offline Ronnie91

  • Post: 2658
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #8 il: 13 Agosto 2012 14:38:25 »
Ciao, il problema credo sia proprio Prevx: http://forum.mozillaitalia.org/index.php?topic=55959.0

Per la pubblicità c'è Adblock Plus: https://addons.mozilla.org/it/firefox/addon/adblock-plus/

Offline jumborex

  • Post: 7
    • http://www.cantodellasfinge.net/
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #9 il: 13 Agosto 2012 18:14:23 »
Ciao, il problema credo sia proprio Prevx: http://forum.mozillaitalia.org/index.php?topic=55959.0
Ho paura che tu abbia proprio ragione. :shock: Ci sono notizie esterne su questo problema? Con esterne intendo non provenienti da Firefox, né da PREVX. Ad ogni modo adesso cerco di chiedere anche a PREVX!

Per il momento (dovesse servire a qualcuno) Firefox se riparte non lo fa per sempre: una volta chiuso il computer e ripartiti, il problema si ripresente identico a prima.
Sono entrato nel pannello di Prevx 3.0 e ho disabilitato la protezione (cosa che si può fare solo per un certo periodo). Da quel momento, infatti, Firefox parte normalmente.
« Ultima modifica: 13 Agosto 2012 18:21:29 da jumborex »

Offline jumborex

  • Post: 7
    • http://www.cantodellasfinge.net/
Re: Improvvisamente Firefox non si avvia (Windows 7)
« Risposta #10 il: 13 Agosto 2012 19:15:02 »
Ho parlato con Prevx e mi hanno detto che il problema è noto:

http://www.wilderssecurity.com/showthread.php?t=328862

In pratica disabilitando il componente Prevx Safeonline, tutto dovrebbe funzionare. A me funziona. :fx2:

Qualcuno mi dice anche di chiedere la nuova versione Prevx: ho contattato il servizio Clienti e vedremo.

http://www.wilderssecurity.com/showthread.php?t=330166

Grazie di tutto.

0 Utenti e 1 Visitatore stanno visualizzando questo topic.